Did I count my trouble codes right? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Did I count my trouble codes right?

Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955XHD Heavy-Duty Hood Latches for JK and TJ available at OcoFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 07-20-2009, 06:35 AM   #1
TJsZJ
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Omaha,NE
Posts: 47
Did I count my trouble codes right?

So I just found out from this wonderful forum how to check my trouble codes. So I head out to the Heep, did the key On-Off thing. Now here comes the part I am a little confused on- the Check Engine light flashed 3 times,paused, flashed 5 times, paused and then 5 more times. While this was happening the OD/off light flashed 5 times and paused, then flashed 5 more times.

So am I correct in assuming I have a code 13? I also have found 2 different code charts and they are completely different- one says a 13 is the MAP sensor, the other says it is a Speed sensor.Which one is correct? I tend to believe it is the Speed sensor one due to my tranny "searching" between 2nd and 3rd and then when I come to a complete stop it takes a second for it to realize it. (The only reason I think this is because I had the same exact problem my Ram and this fixed it).

Anyways, let me know how bad I screwed this process up and set me straight.

TJsZJ is offline   Reply With Quote
Unread 07-20-2009, 07:39 AM   #2
rm2001wj
Web Wheeler
 
rm2001wj's Avatar
2001 WJ 
 
Join Date: Aug 2005
Location: Memphis, TN
Posts: 3,100
The MAP sensor is 13 and the speed sensor is 15. You need to try the key on/off again. The 55 (the two 5s) that you got signals the end of the codes. You did not mention getting a single flash before the 3, which is what you would need in order to get a 13, so that's why I say you should do the procedure again. Actually, try it several more times so that you get used to the seeing the flashes. It's the CEL that you need to be watching.
__________________
2001 WJ Limited with Quadra-Drive, Kenne Bell Supercharger, 3-inch Kolak exhaust, Stillen rotors (F/R) and MM pads, Addco sway bars (F/R).
rm2001wj is offline   Reply With Quote
Unread 07-20-2009, 08:23 AM   #3
TJsZJ
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Omaha,NE
Posts: 47
Quote:
Originally Posted by rm2001wj View Post
The MAP sensor is 13 and the speed sensor is 15. You need to try the key on/off again. The 55 (the two 5s) that you got signals the end of the codes. You did not mention getting a single flash before the 3, which is what you would need in order to get a 13, so that's why I say you should do the procedure again. Actually, try it several more times so that you get used to the seeing the flashes. It's the CEL that you need to be watching.

I'll try it again on my lunch break, but I did it several times last night. Maybe there was a slight pause between the first 3 blinks so it may be a 12 code then.

Do you happen to have a link or chart of all the codes and what they are? Like I said the 2 I pulled up are COMPLETELY different and they are both supposedly for 92-98 ZJ's.
TJsZJ is offline   Reply With Quote
Unread 07-20-2009, 10:02 AM   #4
TJsZJ
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Omaha,NE
Posts: 47
Ok,did it again and there I guess there is a pause at the beginning. So the sequence is 1 blink,pause,2 blinks, pause,5 blinks,pause,5 blinks. The OD light just did the 5 blinks,pause,5 blinks.So according to one of my charts it says that 12 is battery being disconnected within the last 15 starts.

Also, I think my problem is that the 2 charts I have been looking at are the one for the main computer and the other one is for the tranny?

Anyways, looks like I dont have anycodes but doesnt explain the "searching" between 2nd and 3rd that just started happening out of the sky. Guess I'll drive it around some more and see what happens.

Thanks
TJsZJ is offline   Reply With Quote
Unread 07-20-2009, 10:31 AM   #5
rm2001wj
Web Wheeler
 
rm2001wj's Avatar
2001 WJ 
 
Join Date: Aug 2005
Location: Memphis, TN
Posts: 3,100
Like you say, it seems that you don't have any codes. Here's a link to a list of codes that you can trust.

http://www.nagca.com/grandtech/troubleshootcodes.htm
rm2001wj is offline   Reply With Quote
Unread 07-20-2009, 10:39 AM   #6
TJsZJ
Registered User
1995 ZJ 
 
Join Date: Jun 2009
Location: Omaha,NE
Posts: 47
Quote:
Originally Posted by rm2001wj View Post
Like you say, it seems that you don't have any codes. Here's a link to a list of codes that you can trust.

http://www.nagca.com/grandtech/troubleshootcodes.htm
Thanks, much better then one I found.
TJsZJ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.