Dash lights flashing, loss of tail lights - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 02-05-2011, 09:22 AM Thread Starter
ZOG
Registered User
 
Join Date: Feb 2011
Location: NEW BRITAIN
Posts: 6
Dash lights flashing, loss of tail lights

97 grand Laredo

A few weeks ago, while driving at night, all my lights started to pulse on and off, (head lights and dash panel lights). Light switch was set to AUTO.
Turning off ignition, or turning light switch from auto to ON, would stop this.
It happened once a week or so.

Now, I have no tail lights, nor dash lights at all, when switch is ON.
When switch is moved to AUTO the dash lights will flash, but still no tail lights.

All fuses appear to be fine. Battery is relatively new.

Researching this problem here, many people think the ignition switch is to blame, some other posts say light switch?

Is there any way to determine, other than replacing both switches? Which would you replace first? Any ideas?


__________________________________________________ __________________________________________________ ___

Update, No one has a light switch in stock locally, will take 2-3 days to get.
Now, when on AUTO , hit the brakes , the dash lights continue to flash, still no tail lights at all.
Thanks


Last edited by ZOG; 02-05-2011 at 02:46 PM.
ZOG is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 02-05-2011, 10:30 AM
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Posts: 6,557
If you consider switching from auto to on changed the charactorics of the issue , I would have to vote for the light switch itself being the issue
newfieZJ is offline  
post #3 of 7 Old 02-05-2011, 10:31 AM
94chb
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2009
Location: Whitwell
Posts: 1,936
sounds like it could be a bad relay, its under the passenger kick panel
94chb is offline  
post #4 of 7 Old 02-05-2011, 10:57 AM
JS97ZJ
Registered User
2004 WJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry
Posts: 2,279
Ratmonkey answered a similar question yesterday

http://www.jeepforum.com/forum/f13/a...iving-1163252/

POST #5......when checking in the FSM, it made a whole lot of sense. A marvel of electrical engineering......
JS97ZJ is offline  
post #5 of 7 Old 02-05-2011, 02:47 PM Thread Starter
ZOG
Registered User
 
Join Date: Feb 2011
Location: NEW BRITAIN
Posts: 6
Quote:
Originally Posted by 94chb View Post
sounds like it could be a bad relay, its under the passenger kick panel
I was wondering if this was the case, I'll check the relay out.
ZOG is offline  
post #6 of 7 Old 02-05-2011, 09:07 PM
MarkInTombstone
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: Tombstone
Posts: 139
Could be the switch

You'd be doing me a favor if you called me Mark or Tombstone, but not both.
MarkInTombstone is offline  
post #7 of 7 Old 02-06-2011, 03:48 PM Thread Starter
ZOG
Registered User
 
Join Date: Feb 2011
Location: NEW BRITAIN
Posts: 6
Quote:
Originally Posted by ZOG View Post
I was wondering if this was the case, I'll check the relay out.
Quote:
Originally Posted by 94chb View Post
sounds like it could be a bad relay, its under the passenger kick panel
OK , checked a few things and NO luck.
Took apart the light switch and saw some discoloration on the contacts, cleaned them up, reinstalled, no change.
Checked the relays and all seem good, all fuses are OK, too.


Is it the ignition switch?
I couldn't get at that as I didn't have a security torx T20. I'll have to get one this week.

I'd really just like to get the tail lights working, can't drive after dark now.
ZOG is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Lights keep flashing on and off on dash! machurtado WK Grand Cherokee & XK Commander Forum 27 03-10-2016 11:49 AM
Fried wire = no tail lights or dash lights kowboydmac ZJ Grand Cherokee Forum 3 05-20-2010 12:19 PM
Dash comp flashing tail light fault- but lights work??? Loki702 ZJ Grand Cherokee Forum 4 10-28-2008 07:19 AM
Dash lights flashing Doo Hauler WK Grand Cherokee & XK Commander Forum 10 01-12-2008 07:05 AM
No dash lights or tail lights - instantly blowing fuses oxrageous ZJ Grand Cherokee Forum 2 11-01-2007 08:00 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome