Dana 30 Spartan locker axle shaft loose popping sound - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Dana 30 Spartan locker axle shaft loose popping sound

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRuffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO

Reply
Unread 12-13-2013, 06:50 PM   #1
ian_red-zj
Registered User
1998 ZJ 
 
Join Date: May 2013
Location: Whitmore, California
Posts: 282
Dana 30 Spartan locker axle shaft loose popping sound

Anybody have problems after installing a Spartan locker in a stock Dana 30 with 27 spline shafts? My passenger side axle shaft seems loose, to where I'm able to wiggle it up and down a bit, and I don't think any power is going to that tire. With the car in the air I spun the front pass. tire and the driver side did not move at all, and the locker didn't make a clicking sound like it's supposed to. I'm pretty sure the locker was installed correctly, and it originally clicked when spinning the tires in opposite directions as the instructions said it should, but it doesn't do that now. There's also a slight constant pull to the right when driving, and a popping sound when turning right, sometimes its loud and violent sounding like when turning in reverse, but it's usually pretty mild but noticeable. The locker's been in for about two months, and I started noticing this problem about two weeks ago. I haven't done any real hardcore wheeling or anything with the front end banging up and down against rocks or anything like that. I don't know if its a problem with the splines where it meets the case in the dif or a ball joint problem, or something else. I guess that's why I'm askin... thanks a billion

ian_red-zj is offline   Reply With Quote Quick reply to this message
Unread 12-13-2013, 07:10 PM   #2
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 5,841
Sounds like the passenger axle is disconnected from the locker. Check the axle CV joint. Hopefully just that is busted. If it's ok, I'd pull the diff cover and have a look asap.
HighLonesome is online now   Reply With Quote Quick reply to this message
Unread 12-31-2013, 06:51 PM   #3
ian_red-zj
Registered User
1998 ZJ 
 
Join Date: May 2013
Location: Whitmore, California
Posts: 282
Yep, the passenger cv joint was completely busted. All the little pieces were moving around. Upgraded to u-joints
ian_red-zj is offline   Reply With Quote Quick reply to this message
Reply

Tags
dana 30 , dana 30 carrier , dana 30 lock rite , spartan locker

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.