cruise control indicator light not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > cruise control indicator light not working

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 05-07-2013, 03:37 PM   #1
flynvfr
Registered User
1996 ZJ 
 
Join Date: May 2008
Location: Durham, North Carolina
Posts: 15
cruise control indicator light not working

Anyone have any fix for a cruise control light that won't come on. Cruise works fine, fuse under dashboard is OK, but from their I'm lost. Read somewhere that power to the cruise control fuse might be served by the power control unit/box under the hood. I located the box, opened the lid, and there's a bunch of electrical connections and what appear to be fuses. But don't have any specs on what's being regulated in the box, or if there is indeed service to the cruise control fuse. There are no other electrical issues with the vehicle. Thanks for any suggestions.

flynvfr is offline   Reply With Quote
Unread 05-07-2013, 05:22 PM   #2
tucsonzj
Registered User
2000 TJ Wrangler 
 
Join Date: Jul 2012
Location: Boston, MA
Posts: 2,144
welcome to having a zj? haha, honestly, mine doesn't work, neither does my "you're not wearing your seatbelt" or my abs light. Check engine does tho, only one I care about
__________________
"washing it inside and out is on my to-do, eventually, maybe, if I have time, OOOH angle grinder."
tucsonzj is offline   Reply With Quote
Unread 05-07-2013, 05:26 PM   #3
durango-bob
Registered User
2000 TJ Wrangler 
 
Join Date: Jul 2008
Location: Sioux Falls, South Dakota
Posts: 2,785
I might just be a burnt out bulb in the cluster.
durango-bob is offline   Reply With Quote
Unread 05-07-2013, 05:44 PM   #4
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Please fill in your Jeep profile info. Year, engine, etc.
Displays...
<--- over there

Which year?

Cruise control lamp started in 96.
93-95 clusters don't have one.
KoreaZJ is offline   Reply With Quote
Unread 05-08-2013, 05:47 AM   #5
flynvfr
Registered User
1996 ZJ 
 
Join Date: May 2008
Location: Durham, North Carolina
Posts: 15
Quote:
Originally Posted by KoreaZJ View Post
Please fill in your Jeep profile info. Year, engine, etc.
Displays...
<--- over there

Which year?

Cruise control lamp started in 96.
93-95 clusters don't have one.
It's a 96. Just stopped working a few weeks ago. But it's really not a big deal. Just was wondering if there really was truth to some other electrical control box (under the hood) that served the fuses under dask. In reality, I think I can figure out when the cruise is on or off.
flynvfr is offline   Reply With Quote
Unread 05-08-2013, 05:50 AM   #6
flynvfr
Registered User
1996 ZJ 
 
Join Date: May 2008
Location: Durham, North Carolina
Posts: 15
Quote:
Originally Posted by tucsonzj View Post
welcome to having a zj? haha, honestly, mine doesn't work, neither does my "you're not wearing your seatbelt" or my abs light. Check engine does tho, only one I care about
Yea. For going on 25+ years ya gotta expect some dash bulbs to start failing.
flynvfr is offline   Reply With Quote
Unread 05-08-2013, 06:16 AM   #7
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Since your cruise works, then likely the cluster bulb needs replacing.

Cluster rear view...
KoreaZJ is offline   Reply With Quote
Unread 05-08-2013, 06:56 AM   #8
Skyarcher
Registered User
1998 ZJ 
 
Join Date: May 2013
Location: Telluride, Colorado
Posts: 4
I've never seen mine working, which indicator is it?
Skyarcher is offline   Reply With Quote
Unread 05-08-2013, 07:50 AM   #9
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Quote:
Originally Posted by Skyarcher View Post
I've never seen mine working, which indicator is it?
One with the red circle in the pic.

Next to Check Engine, right side (viewing from cluster front).
KoreaZJ is offline   Reply With Quote
Unread 05-08-2013, 09:59 PM   #10
Skyarcher
Registered User
1998 ZJ 
 
Join Date: May 2013
Location: Telluride, Colorado
Posts: 4
Thanks
Skyarcher is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.