cruise control doesnt work - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > cruise control doesnt work

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueBest deals on Yukon Gears at JeepHut.comNeed Ace Engineering products? JeepHut has you covered.

Reply
Unread 04-07-2005, 10:01 PM   #1
2tone93zj
Registered User
1993 ZJ 
 
Join Date: Dec 2004
Posts: 587
cruise control doesnt work

on my 93 grand 4.0L, the cruise doesnt work, i used to keep it on the "ON" position all the time and when i needed it i would just set it. now it doesnt work at all i checked the fuses whats next?

2tone93zj is offline   Reply With Quote
Unread 04-07-2005, 10:18 PM   #2
Brian's 97 ZJ
Registered User
1997 ZJ 
 
Join Date: Jun 2001
Location: SW Michigan
Posts: 372
2tone93zj,

The next thing that I would check would be the vaccume line. If the line has been disconnected or a hole has been worn in it somehow your cruise will not work. The line is connected to your intake manifold and (I'm guessing here) runs over to the passanger side of the engine compartment to a round/cone shaped thingamajig.

After that I would start to suspect the switch.

HTH

- Brian
__________________

For some reason, being a member of the CharGold Jeep Club just isn't as cool... Member #1
Brian's 97 ZJ is offline   Reply With Quote
Unread 04-07-2005, 10:26 PM   #3
grandman97
Web Wheeler
 
Join Date: Jan 2005
Location: Trumbull,CT
Posts: 1,194
man you've gots some balls to be offroading w/ cruise control on.. u are offroading right??
grandman97 is offline   Reply With Quote
Unread 04-07-2005, 10:36 PM   #4
Brian's 97 ZJ
Registered User
1997 ZJ 
 
Join Date: Jun 2001
Location: SW Michigan
Posts: 372
Yeah, isn't the minimum cruise speed about 30 mph?

- Brian
__________________

For some reason, being a member of the CharGold Jeep Club just isn't as cool... Member #1
Brian's 97 ZJ is offline   Reply With Quote
Unread 04-08-2005, 12:13 AM   #5
grandman97
Web Wheeler
 
Join Date: Jan 2005
Location: Trumbull,CT
Posts: 1,194
yea it is i have always wanted to be able to set my cruise for like 10-15mph for those really slow moving traffic jams... it sucks u cant do it under 30
grandman97 is offline   Reply With Quote
Unread 10-02-2009, 12:49 AM   #6
IslandManMitch
Registered User
1996 ZJ 
 
Join Date: Feb 2007
Location: Florida
Posts: 107
I wish mine could be set to at 25 MPH but I have to be going at least 35 MPH.
IslandManMitch is offline   Reply With Quote
Unread 10-02-2009, 01:28 AM   #7
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,805
If you only have defrost on your heater you have a vac leak(one line feeds both).

If you have overdrive torque converter lock and unlock issues you have a bad brake switch.

Most likely is that you killed the cruise control unit by leaving it on constantly. They're known to do that.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.