Crank but won't start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Crank but won't start

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 07-05-2009, 10:28 AM   #1
dstockton
Registered User
 
Join Date: Jul 2009
Location: tulsa
Posts: 2
Crank but won't start

I have a 2000 Jeep Grand Cherokee and I haven't had any problems with it but today I pulled out of my drive way and it died and now it won't start.

It has power and cranks but doesn't start. Kind of like me fuel pump isn't working. But i don't think its that because when I turn my key on my gauges barely move.

i've been reading around on this forum and kind of thought it might be the crank sensor from what others have experienced.

Any ideas?


Thanks ahead.

dstockton is offline   Reply With Quote
Unread 07-05-2009, 10:59 AM   #2
tfgnt16
Registered User
2009 WK 
 
Join Date: Nov 2008
Location: Long Island, New York
Posts: 316
I just had this problem yesterday morning, except I was driving down the parkway at about 55 when it died on me. All signs lead to the CPS going bad. On your dash, do any gauges register, is your engine light and sentry key light on at all?

My jeep is sitting at a dealer 5 miles away, I might go run over there today and play with the CPS wires and harness just to see if that's the problem.
__________________
2001 WJ Laredo 4.0L - Sold!
2009 WK Limited 5.7L HEMI
tfgnt16 is offline   Reply With Quote
Unread 07-05-2009, 08:44 PM   #3
dstockton
Registered User
 
Join Date: Jul 2009
Location: tulsa
Posts: 2
I had a independant mechanic tell me today it was the pcm and only the dealership could fix it. What do you think?
dstockton is offline   Reply With Quote
Unread 07-28-2009, 06:20 PM   #4
thelazyman
Registered User
 
Join Date: Jul 2009
Location: Mass
Posts: 1
I have the same issue with my 2000 grand cherokee 4.0. Ran fine yesturday and today it just cranks but doesn't start. I filled it up yesterday as well. Now my fule light is on, the gas gauge reads empty and my voltage reads 9 volts. However I know I have gas, and the engine cranks over fast so it isn't the battery. Did anyone figure out what the problem was?
thelazyman is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.