Crank but won't start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 07-05-2009, 10:28 AM Thread Starter
dstockton
Registered User
 
Join Date: Jul 2009
Location: tulsa
Posts: 2
Crank but won't start

I have a 2000 Jeep Grand Cherokee and I haven't had any problems with it but today I pulled out of my drive way and it died and now it won't start.

It has power and cranks but doesn't start. Kind of like me fuel pump isn't working. But i don't think its that because when I turn my key on my gauges barely move.

i've been reading around on this forum and kind of thought it might be the crank sensor from what others have experienced.

Any ideas?


Thanks ahead.

dstockton is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-05-2009, 10:59 AM
tfgnt16
Registered User
2009 WK 
 
Join Date: Nov 2008
Location: Manhattan
Posts: 320
I just had this problem yesterday morning, except I was driving down the parkway at about 55 when it died on me. All signs lead to the CPS going bad. On your dash, do any gauges register, is your engine light and sentry key light on at all?

My jeep is sitting at a dealer 5 miles away, I might go run over there today and play with the CPS wires and harness just to see if that's the problem.

2001 WJ Laredo 4.0L - Sold!
2009 WK Limited 5.7L HEMI
tfgnt16 is offline  
post #3 of 4 Old 07-05-2009, 08:44 PM Thread Starter
dstockton
Registered User
 
Join Date: Jul 2009
Location: tulsa
Posts: 2
I had a independant mechanic tell me today it was the pcm and only the dealership could fix it. What do you think?
dstockton is offline  
post #4 of 4 Old 07-28-2009, 06:20 PM
thelazyman
Registered User
 
Join Date: Jul 2009
Location: Mass
Posts: 1
I have the same issue with my 2000 grand cherokee 4.0. Ran fine yesturday and today it just cranks but doesn't start. I filled it up yesterday as well. Now my fule light is on, the gas gauge reads empty and my voltage reads 9 volts. However I know I have gas, and the engine cranks over fast so it isn't the battery. Did anyone figure out what the problem was?
thelazyman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1997 5.2 crank but no start, need help with crank sensor replacement. titan66 ZJ Grand Cherokee Forum 8 01-28-2011 07:34 PM
96 Zj 4.0 Crank No Start bigbill888 ZJ Grand Cherokee Forum 5 01-15-2010 08:12 AM
4.7 crank no start 95pathy ZJ Grand Cherokee Forum 8 11-07-2009 01:15 PM
4.0 will not crank/start lakailimited06 ZJ Grand Cherokee Forum 4 11-07-2009 10:00 AM
Won't start on first crank. 7thStranger ZJ Grand Cherokee Forum 6 07-02-2004 11:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome