Coolant Smell on 2002 Grand Cherokee – No heater core symptoms - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Coolant Smell on 2002 Grand Cherokee – No heater core symptoms

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 03-04-2010, 01:30 PM   #1
GS Audio
Registered User
2002 WJ 
 
Join Date: Oct 2005
Location: NYC (Tri-State)
Posts: 274
Coolant Smell on 2002 Grand Cherokee – No heater core symptoms

This one is a mind boggler……

Got this Jeep in 2008 with a bad heater core. Bought the heater treater kit, new core, and new evap….figure I’d replace all in one shot while in there. This was done December 2008.

Core went bad again after 7 or 8 months and was replaced free in September 2009. The coolant smell stuck around though. Heat works great, defrost does too with no residue on the window. When I step out of the Jeep after a drive, I smell the coolant more around the front/engine area.

Coolant level is fine, no smoke or smells from exhaust, oil is clean, so I’ve ruled out head gasket, and there are no leaks in the driveway, garage, or parking spot at work.

Could there be some microscopic leak at one of the hoses or radiator? And then the heater sucks the smell from the engine bay into the vehicle?

It just doesn’t add up what could be causing the smell…..

Anyone?

Thanks!

__________________
The current line-up:
2002 WJ Overland 4.7HO
1996 Jeep Cherokee Sport (AX-15 :D)
2007 Chevy Trailblazer SS 6.0 V8
GS Audio is offline   Reply With Quote
Unread 03-04-2010, 05:05 PM   #2
Double E
2000 Laredo V8
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 3,463
How about a pinhole leak in the system such as this?

http://www.jeepforum.com/forum/f13/4...-avail-971799/
__________________
2000 Laredo 4.7L Selec-Trac. 177K miles, Leather, 245 tires, tow package, crappy CD changer, full size spare, roof cross-rails & sunroof.
Changes & fixes: Rear Addco sway bar & greasble bushings, upgraded headlights, upgraded tail lights, new hood struts (replaced 2X), new rear hatchglass struts, new radiator (replaced 3X), new oil pressure sending unit (replaced 4X), 2 new speed sensors, 2 new door lock actuators, new ignition key cylinder, chrome front tow hooks, Mobil 1 Synthetic 5/30, Purolator Pure One oil filter, EBC slotted & dimpled rotors, EBC Greenstuff pads, new front shocks (replaced 3X), new rear shocks (replaced 2X), new IRO steering stabilizer, new timing chain cover, new water pump, thermostat, new thermostat housing, new high pressure power steering hose, Michelin-X radials, new sunroof assembly, new single-piece lug nuts, new exhaust manifold studs & gasket on driver's side, new Durango alternator. Jeepforum.com sticker, Visit cobaltboatsforum.com when you can!
Double E is offline   Reply With Quote
Unread 03-04-2010, 08:01 PM   #3
GS Audio
Registered User
2002 WJ 
 
Join Date: Oct 2005
Location: NYC (Tri-State)
Posts: 274
Quote:
Originally Posted by Double E View Post
How about a pinhole leak in the system such as this?

http://www.jeepforum.com/forum/f13/4...-avail-971799/
Don't think this is my issue.....no missing coolant, not one drop. I do smell the coolant in that general area.....so maybe we're onto something?

What are typical signs of a failing water pump (if any?)?
__________________
The current line-up:
2002 WJ Overland 4.7HO
1996 Jeep Cherokee Sport (AX-15 :D)
2007 Chevy Trailblazer SS 6.0 V8
GS Audio is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.