"Coolant Sensor Bad" - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 06-19-2007, 06:31 PM Thread Starter
seth586
Registered User
 
Join Date: Jun 2006
Location: Manhattan, KS
Posts: 67
"Coolant Sensor Bad"

My center console says "cooland sensor bad", is this the thermostat or a different sensor? Thanks,


1996 ZJ 5.2L
4.5" RE Superflex
265x75x16 BFG ATs
Thule Roof Rack, K&N FIPK
seth586 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-19-2007, 06:50 PM
SpeedyCat3
Survivor
 
SpeedyCat3's Avatar
1997 ZJ 
 
Join Date: Dec 2002
Location: Planet Earth
Posts: 2,653
Quote:
Originally Posted by seth586
My center console says "cooland sensor bad", is this the thermostat or a different sensor? Thanks,

Uhmmmmm...Let me see what a quick search brings up....


http://www.jeepforum.com/forum/searc...archid=1213006

Ok...
You'll see that the sensor the VIC takes the reading from is the level sensor inside the reservoir, not the engine one.
If you change it, flush the reservoir of all the crud that accumulates, and clean the connector.
If the message persists, but intermittent, the problem mor likely lies in a faulty VIC, which has been traced to be craked or broken solder points.

Try the easy fix first..
But before you do it, read some of the gazillion other posts, that might give more ideas on how to go about it....

_o o o o_
|_Jeep_|
(OlllllllO)
[] ---o-[]

My 97 ZJ Build
SpeedyCat3 is offline  
post #3 of 6 Old 06-19-2007, 06:58 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
The coolant temperature sensor (the one on the thermostat) is a very important sensor for fuel management and a code will be thrown if that one goes bad (which is not your issue)

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #4 of 6 Old 06-20-2007, 11:14 PM Thread Starter
seth586
Registered User
 
Join Date: Jun 2006
Location: Manhattan, KS
Posts: 67
I searched for "coolant sensor bad", but nothing came up. I did try, and thanks for the help =)

1996 ZJ 5.2L
4.5" RE Superflex
265x75x16 BFG ATs
Thule Roof Rack, K&N FIPK
seth586 is offline  
post #5 of 6 Old 06-21-2007, 11:34 AM
SpeedyCat3
Survivor
 
SpeedyCat3's Avatar
1997 ZJ 
 
Join Date: Dec 2002
Location: Planet Earth
Posts: 2,653
Check the link I showed you.. there are at least 5 or 6 threads there.

And no prob... I have a weird sense of humor some times, but I was just kidding.

_o o o o_
|_Jeep_|
(OlllllllO)
[] ---o-[]

My 97 ZJ Build
SpeedyCat3 is offline  
post #6 of 6 Old 06-21-2007, 11:35 AM
SpeedyCat3
Survivor
 
SpeedyCat3's Avatar
1997 ZJ 
 
Join Date: Dec 2002
Location: Planet Earth
Posts: 2,653
By the way, I have to do that same fix, cause I have that same problem right now, so I do it soon I'll post in this same thread.

_o o o o_
|_Jeep_|
(OlllllllO)
[] ---o-[]

My 97 ZJ Build
SpeedyCat3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
"Coolant Sensor Bad" FINALLY FIXED!!!! phild328 ZJ Grand Cherokee Forum 139 02-08-2016 08:17 AM
"Coolant Sensor is bad" jhillstead ZJ Grand Cherokee Forum 4 07-02-2009 10:18 PM
96 GC. "Coolant Sensor Bad", Which sensor? seanf ZJ Grand Cherokee Forum 2 07-14-2007 04:16 PM
"Coolant Sensor Bad"?? on '96 ZJ 5.2 oneillsean ZJ Grand Cherokee Forum 16 09-17-2006 12:14 PM
"Coolant sensor bad" Rock1127 ZJ Grand Cherokee Forum 1 10-01-2005 09:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome