Coolant Level Low??? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 01-25-2005, 08:57 PM Thread Starter
Jay Arno
Registered User
 
Join Date: Jan 2005
Location: Richmond, Va
Posts: 14
Coolant Level Low???

So my overhead console went crazy acouple days ago, saying the coolant level was low....now it's fine. It was a cold night/morning could that be it. I haven't been able to check. I'll check it tomorrow.

Jay Arno is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-26-2005, 09:08 AM
coolest_Stan
Registered User
 
Join Date: Jan 2005
Posts: 590
even if it is low, its an easy easy easy easy fix. im a n00b and I fiex it all by myself on my first try. Just mix it 50/50 water/coolant soultion
Then pour it into the right tank. And you can find the correct tank, if it is in the upper left hand corner, or if it has "full" and "add" on the sides of it. You probably odnt need this but I figured I would just help some n00bs out
coolest_Stan is offline  
post #3 of 5 Old 01-26-2005, 09:21 AM
mr_user
Registered User
 
Join Date: Sep 2004
Location: Fairfield, CT and Oxford, OH
Posts: 2,068
Your check would determine whether or not the sending unit is going bad. If the coolant is easily full, your sending unit might need replacement. It is not difficult, and pretty cheap IIRC.

Keep in mind though those things have a pretty low threshold, and flash the "idiot lights" easily. In other words, what may look like full to you may be considered too low by the ECU.

Also Stan, the days of mixing coolant with water are over. Most coolants come pre 50/50 mixed with distilled water from the factory. When you are coolant shopping, be sure to closely read the ingredients on each bottle you will be surprised. For some reason the $8 Prestone has the exact same ingredients as the $3 "Car And Driver" brand..

Old: '96 ZJ 4.0, 32" MT/R's, 4.5" Lift, Mickey Thompsons, JKS Disco's

New: '02 WJ Limited 4.7L, Stock for now
mr_user is offline  
post #4 of 5 Old 01-26-2005, 05:16 PM
Animal Mother
Registered User
 
Animal Mother's Avatar
 
Join Date: Jan 2005
Location: Dallas, Texas
Posts: 364
My jeep is always telling me my coolant level is low and rarely is it ever past the "ADD" mark. Is something wrong with the wiring because this is extremely agrivating.

96 5.2L ZJ Limited Forrest Green
Animal Mother is offline  
post #5 of 5 Old 01-26-2005, 07:08 PM
coolest_Stan
Registered User
 
Join Date: Jan 2005
Posts: 590
it needs to be PAST the add mark! so fill it!
and mine is 50/50, just look on the back of the bottle, and it should say
coolest_Stan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.0L Coolant level tfgnt16 ZJ Grand Cherokee Forum 2 12-22-2008 07:15 PM
2001 GC low coolant level light Steve in PA ZJ Grand Cherokee Forum 2 10-18-2008 11:30 AM
Low coolant level kopite77 ZJ Grand Cherokee Forum 14 02-12-2007 09:53 AM
Coolant level sensor bad - is this serious? Gracie ZJ Grand Cherokee Forum 10 11-18-2004 07:19 PM
low coolant level alarm msafrit ZJ Grand Cherokee Forum 3 01-23-2003 07:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome