JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   cold start/idle/run intermittent issue (http://www.jeepforum.com/forum/f13/cold-start-idle-run-intermittent-issue-1687385/)

philWJHuntley 10-15-2013 02:11 PM

cold start/idle/run intermittent issue
 
My grand Cherokee 4.0 (65,000m) has just been serviced, new battery, new starter motor (this issue broke the original).
For years it has had a mild idle issue and seems to always hunt slightly. It is much worse now, where some days, I have to put the gas peddle to the floor and painfully crank until it starts which it usually does (good ole jeep!). I had to do this every time until a recent overdue service. Despite the service there is a problem still. Once it starts it then idles terribly and drives badly although this sometimes clears after a while. Others days it starts and drives ok!
At the moment I cannot drive it, when revved in Park or I try and drive it, it looses power and misses. It seems, when under pressure, it folds like it is being starved of fuel or a spark.
Any advice would be much appreciated.
Phil (London, UK)

ZeeJay1997 10-15-2013 07:16 PM

are you running petrol or LP?

If you're running petrol. sounds like the fuel pressure may be the issue. There's a port on the fuel rail to attach a gauge. Should be reading 49 plus or minus 5 PSI

philWJHuntley 10-22-2013 07:31 AM

Thanks ZeeJay
it is fuel - i'll get that tested.

is LP worth doing?

ZeeJay1997 10-22-2013 08:05 PM

Quote:

Originally Posted by philWJHuntley (Post 17044458)

is LP worth doing?

I dont know because that's a UK thing. I know of at least on forum member over there that has a dual fuel unit.


The time now is 03:44 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.