Coil Problems - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 10-18-2007, 12:03 PM Thread Starter
93JeepZJ
Registered User
 
Join Date: Jan 2007
Location: Michigan
Posts: 182
Coil Problems

Well my jeeps been in and out of the shop 3 times in the last 2 weeks. First time it was the coil, drove for about 20 miles and shut off... ended up being the distributer and coil. Drove it again for about 100miles until it shut off. They called and said it was the coil again. They researched the problem and i guess back in 1993 there was a service bulletin for the coil pack and wiring harness for it.
Next day i get a call and find out that there is only one kit left in the U.S. and its in hawaii and its going to be 3-5 days till they get the part! anyone else run into this coil problem?


'93 Jeep ZJ- 4.0L/249NP/42RE, 2" BB, 31" ProComp A/T's
'01 Monte Carlo SS- Supercharged/Cam/Headers
www.cardomain.com/id/montecarlo97z
93JeepZJ is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-18-2007, 12:14 PM
93GrandZJ
Registered User
1993 ZJ 
 
Join Date: Oct 2007
Location: ks
Posts: 176
you must have an early 93 with the pole type terminals on the coil. the later 93s (like mine) already had the "updated" coil and the harness you are talking about. it runs up to the alternator (i think) and is zip tied off to the alternator.

i have still replaced the "new coil" three or four times in 198+K miles. i can't remember if the harness will "upgrade" you to the newer coil...

Last edited by 93GrandZJ; 10-18-2007 at 12:33 PM.
93GrandZJ is offline  
post #3 of 8 Old 10-18-2007, 12:15 PM
driabyor
Registered User
 
driabyor's Avatar
1994 ZJ 
 
Join Date: Apr 2004
Location: chilton-haynes<$20
Posts: 2,450
I went thru several coils at one point. I bolted the first two back to the bracket , with the 3 foot long bolts.... I cussed both times... the third time,well the second coil is still on the jeep. the Third one is ziptied to the old coil... no problems for at least 100,000 miles.

94 Grand Cherokee ... 332,000 miles
5.2 liter 242 :)
Rancho 5000 steering stabilizer
driabyor is offline  
post #4 of 8 Old 10-18-2007, 12:19 PM
93GrandZJ
Registered User
1993 ZJ 
 
Join Date: Oct 2007
Location: ks
Posts: 176
Quote:
Originally Posted by driabyor
I bolted the first two back to the bracket , with the 3 foot long bolts....
no kidding, they are long
93GrandZJ is offline  
post #5 of 8 Old 10-18-2007, 12:29 PM Thread Starter
93JeepZJ
Registered User
 
Join Date: Jan 2007
Location: Michigan
Posts: 182
i hoping that this will fix the problem and i can drive it for more then a day! i miss my jeep and i need to get it home so i can get some new tires on it before winter. all together with towing and repair bills this has cost me over $500 and its not fixed yet

'93 Jeep ZJ- 4.0L/249NP/42RE, 2" BB, 31" ProComp A/T's
'01 Monte Carlo SS- Supercharged/Cam/Headers
www.cardomain.com/id/montecarlo97z
93JeepZJ is offline  
post #6 of 8 Old 10-18-2007, 12:35 PM
93GrandZJ
Registered User
1993 ZJ 
 
Join Date: Oct 2007
Location: ks
Posts: 176
Quote:
Originally Posted by 93JeepZJ
drove for about 20 miles and shut off... ended up being the distributer and coil. Drove it again for about 100miles until it shut off. They called and said it was the coil again.
on mine when the coil(s) went it did not just shut off. it would sputter and spit and miss and eventually stall. you could get it started again, but it would do the same thing. if you did not keep on the gas it would stall.

sure it's the coil?

Last edited by 93GrandZJ; 10-18-2007 at 01:46 PM.
93GrandZJ is offline  
post #7 of 8 Old 10-19-2007, 11:31 AM Thread Starter
93JeepZJ
Registered User
 
Join Date: Jan 2007
Location: Michigan
Posts: 182
ya every time they replace it, it runs fine. the times it went out it would backfire and shut off then wouldnt start. i wish it would just spit and sputter... then i could get it home and fix it myself instead of paying $$$$ for repair bills at a shop

'93 Jeep ZJ- 4.0L/249NP/42RE, 2" BB, 31" ProComp A/T's
'01 Monte Carlo SS- Supercharged/Cam/Headers
www.cardomain.com/id/montecarlo97z
93JeepZJ is offline  
post #8 of 8 Old 10-19-2007, 11:44 AM
CLNinja
Registered User
 
CLNinja's Avatar
1993 ZJ 
 
Join Date: Apr 2007
Location: Denver, CO
Posts: 6,977
this is why i love the MSD coil i put on my 93 ( built in 92 )

Matt
**September 2009 Grand Cherokee Of The Month**
Colorado Jeep Club Member #88
CLNinja is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Repeat Coil Pack Problems PreacherTJ ZJ Grand Cherokee Forum 2 05-12-2009 03:16 PM
Coil Sag ZJ-Soldier ZJ Grand Cherokee Forum 1 03-04-2009 08:17 PM
Mudding problems.....What do you guys do to prevent problems? JackAysJake ZJ Grand Cherokee Forum 8 02-23-2009 09:02 PM
Ignition coil problems the whole time maybe? speedbullet2 ZJ Grand Cherokee Forum 11 03-09-2008 01:15 PM
Alternator problems??? Shock problems??? rflem550 ZJ Grand Cherokee Forum 11 01-24-2007 06:41 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome