CKP question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > CKP question

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 05-29-2004, 07:12 PM   #1
sentinal02
H2 Recovery Team Member
 
sentinal02's Avatar
1992 YJ Wrangler 
 
Join Date: Feb 2003
Location: New York
Posts: 6,688
CKP question

Hey guys,
I'm trying to help my uncle figure out what's wrong on his 93 ZJ, 4.0. It keeps dying on him after it warms up a bit. Let it sit 20 minutes or so and it will start up again without much effort. So far we've changed the dist, rotor, fuel filter, ignition coil, map sensor and O2 sensor. the last two were done based on trouble codes from the computer. What I'm wondering is if it's possible for the CKP sensor to go bad without storing a code in the computer? at this point I'm leaning towards this being the problem if it's possible. Only other thing i can think of would be the fuel pump or pressure regulator. But we have no gauge to test that right now. Any other thoughts? Thanks!

__________________
RIP: '88 YJ 2.5L Ax-5 NP231
Posi-Loked. Herculined. Optima yellow top. 1" Shackle, 2" BDS. Cragar 397's Aussie front.

92 YJ 4.0L Ax-15 231
5" springs, 1" shackle 31's or 35's depending on my mood
sentinal02 is offline   Reply With Quote Quick reply to this message
Unread 05-31-2004, 06:12 PM   #2
sentinal02
H2 Recovery Team Member
 
sentinal02's Avatar
1992 YJ Wrangler 
 
Join Date: Feb 2003
Location: New York
Posts: 6,688
Well, just to update, it is possible for the CPS to go bad without storing a fault code. Finally checked the codes while the ZJ wouldn't start and it retured a code 11. god what a bear that was to change. we've got it easy on the YJ's so far the thing will fire up, but it's still running rough. spitting and sputtering on accel. MAP, coil, dist, rotor, CPS, and O2 sensors are all new. Also, we pulled the muffler off to check the cat and there's nothing in there. Some PO must have cleaned it out. now we just have to figure out why it's not running smoothly. the engine was over heated (260 redline for a few miles) and then run hot from FL to NY (though never that hot again) so I'm wondering if it's just something that was warped finally taking a dump on him. still got the fuel pressure to test though so we'll see. thanks for the help guys!
__________________
RIP: '88 YJ 2.5L Ax-5 NP231
Posi-Loked. Herculined. Optima yellow top. 1" Shackle, 2" BDS. Cragar 397's Aussie front.

92 YJ 4.0L Ax-15 231
5" springs, 1" shackle 31's or 35's depending on my mood
sentinal02 is offline   Reply With Quote Quick reply to this message
Unread 06-01-2004, 02:03 AM   #3
Colorado 5.9
Registered User
1998 ZJ 
 
Join Date: Dec 2001
Location: Denver, Colorado
Posts: 2,049
May be the IAC, plugs or the firering order is messed up now since you changed the dist. cap.
__________________
ZJ 98 5.9 LTD. Lots of mods. 7" T&T's Long Arm Lift ,BFG KM2"s,35X12.50x16's,4:56's, Vanco brake upgrade, M1intake,Holley52mmTB,MikeLeach Headers,, Arb'ed HP D30,Aussie Locked rear,Procomp MX6 Shocks,Arb front,RearTR bumpers,ECT.ECT.

Latest Pics
Colorado 5.9 is offline   Reply With Quote Quick reply to this message
Unread 06-01-2004, 12:44 PM   #4
sentinal02
H2 Recovery Team Member
 
sentinal02's Avatar
1992 YJ Wrangler 
 
Join Date: Feb 2003
Location: New York
Posts: 6,688
Quote:
Originally Posted by Colorado 5.9
May be the IAC, plugs or the firering order is messed up now since you changed the dist. cap.
I double checked the firing order and that's as it should be. I'm not familiar with the IAC, what's that do?
__________________
RIP: '88 YJ 2.5L Ax-5 NP231
Posi-Loked. Herculined. Optima yellow top. 1" Shackle, 2" BDS. Cragar 397's Aussie front.

92 YJ 4.0L Ax-15 231
5" springs, 1" shackle 31's or 35's depending on my mood
sentinal02 is offline   Reply With Quote Quick reply to this message
Unread 06-03-2004, 11:55 PM   #5
Colorado 5.9
Registered User
1998 ZJ 
 
Join Date: Dec 2001
Location: Denver, Colorado
Posts: 2,049
Quote:
Originally Posted by sentinal02
I double checked the firing order and that's as it should be. I'm not familiar with the IAC, what's that do?

It is the Idel AIR Controler. It controls the amount of air fulel mixture. If it is dirty or gone bad the jeep will not idel right or it will chug down the road not alowing the motor to rev. at very high RPM's.
__________________
ZJ 98 5.9 LTD. Lots of mods. 7" T&T's Long Arm Lift ,BFG KM2"s,35X12.50x16's,4:56's, Vanco brake upgrade, M1intake,Holley52mmTB,MikeLeach Headers,, Arb'ed HP D30,Aussie Locked rear,Procomp MX6 Shocks,Arb front,RearTR bumpers,ECT.ECT.

Latest Pics
Colorado 5.9 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.