Chirping noise - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 09-19-2013, 04:15 PM Thread Starter
jeepycreepy96
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Rocky Point
Posts: 87
Chirping noise

Hey guys so in my 96 there's a weird chirping noise at low speed up to about 45 that won't go away. I just replaced the front pads and I haven't looked at the the rears yet. it sounds as if it would chirp at a certain point then the wheels would rotate and chirp like if the rotor is has a high point. Can't tell

jeepycreepy96 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-20-2013, 01:47 AM
jabba974
Registered User
1996 ZJ 
 
Join Date: Mar 2013
Location: Ionia
Posts: 246
Check the brake pads and see if the wear indicator is bent to close to the rotor..or check the clearance on the backing plate...
jabba974 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome