Check engine light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Check engine light

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 08-23-2003, 06:21 PM   #1
Willie1470
Registered User
 
Join Date: Aug 2003
Posts: 11
Check engine light

I had my '98 Grand tuned up friday (22nd) and today when I drove it, the check engine light went on. I'm a novice but did the mechanic forget to do something? Thanks for all your help

Willie

Willie1470 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2003, 08:53 PM   #2
akins1400
Registered User
 
Join Date: Sep 2002
Location: Benton, AR
Posts: 1
Very possible. Take it back and have him check the computer with a code scanner. That should tell him what he left loose. Probably a vacuum hose or an electric connector. You can also have your computer trouble codes checked at a parts store such as Auto Zone.
akins1400 is offline   Reply With Quote Quick reply to this message
Unread 08-25-2003, 08:59 AM   #3
Willie1470
Registered User
 
Join Date: Aug 2003
Posts: 11
Quote:
Originally Posted by akins1400
Very possible. Take it back and have him check the computer with a code scanner. That should tell him what he left loose. Probably a vacuum hose or an electric connector. You can also have your computer trouble codes checked at a parts store such as Auto Zone.
Thanks! Went to mechanic to day, he ran the computer check and it showed up something to do with fuel compression (?), the gas cap was tightened, he also pushed a hose in tighter and everything seems okay. Thanks for helping out a novice....
Willie
Willie1470 is offline   Reply With Quote Quick reply to this message
Unread 08-27-2003, 10:48 PM   #4
Angry Alan
Registered User
2007 WK 
 
Join Date: Aug 2003
Location: Here and there.
Posts: 213
I'm having a similar problem. My 98 5.9L has been to my shop twice now for the Check Engine light. The light is solid, which is a good thing. The problem..

It keeps showing up!

I've had Output Speed Sensor replaced and it work fine for a week. Until the light came BACK on only a few days ago. I took it back to my shop, they hooked up the handheld code reader and the new problem was fixed. Not quite. The damn light came back on earlier today.

Has anyone else had these kind of problems?
Angry Alan is offline   Reply With Quote Quick reply to this message
Unread 09-02-2003, 11:55 AM   #5
automan25
Registered User
 
Join Date: Dec 2002
Location: Kenmore, WA
Posts: 290
Check the engine computer to see what codes are being stored. You can do this by turning the ignition on (don't start the motor, just turn the key to the on position), then off, then on again, then off, finally on a third time. After a few seconds the check engine light will flash the codes at you. Simple count how many times it flashes. The sequence will always begin and end with a 5. After the sequence is complete there will be a longer pause and then it will repeat. Here is what the sequence would be if you had codes 32 and 54 stored in the computer:

5-3-2-5-4-5

Write down the codes and check to see what they mean in a Haynes or Chilton manual.
__________________
1993 ZJ Limited 5.2 - no mods - Red with Gold (what were they thinking) trim.
automan25 is offline   Reply With Quote Quick reply to this message
Unread 09-02-2003, 02:43 PM   #6
Fisher
Registered User
1985 CJ7 
 
Join Date: Aug 2003
Posts: 7
Quote:
Originally Posted by Angry Alan
I'm having a similar problem. My 98 5.9L has been to my shop twice now for the Check Engine light. The light is solid, which is a good thing. The problem..

It keeps showing up!

I've had Output Speed Sensor replaced and it work fine for a week. Until the light came BACK on only a few days ago. I took it back to my shop, they hooked up the handheld code reader and the new problem was fixed. Not quite. The damn light came back on earlier today.

Has anyone else had these kind of problems?
Yeah, Mine has been coming on and I've ended up changing two o2sensors (upstream and downstream) and also the idle position sensor.
Fisher is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.