Cd Player? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Cd Player?

XJ Rail Sale!The Ruffstuff NOT Universal 4 Link Kit!Vanco Big Brake Kit Promotion!

Reply
Unread 09-21-2009, 10:41 PM   #1
ECMUDSLINGER
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Outer Banks N.C.
Posts: 91
Cd Player?

Well here it is i got a new CD player for my 1993 grand wagoner and got a connector kit got home and it was the wrong one it goes up to 1992 i gotta 93..ugh...so i went back and they didn't carry them, does anybody know where to get one i only have a napa and a advance auto near me well a hour away due to me living on a island. any help would be greatly appreciated thanks ECM.

ECMUDSLINGER is offline   Reply With Quote Quick reply to this message
Unread 09-21-2009, 10:48 PM   #2
hamilton5
Registered User
2001 WJ 
 
Join Date: Aug 2009
Location: usa
Posts: 444
online im sure, like crutchfield.com, or even ebay...

http://www.crutchfield.com/p_1207018...ss.html?tp=736
hamilton5 is offline   Reply With Quote Quick reply to this message
Unread 09-21-2009, 11:08 PM   #3
PBNJTJ
Registered User
1998 TJ Wrangler 
 
Join Date: Sep 2009
Location: So. Cal., California
Posts: 56
^ Crutchfield.com for sure. Do yourself a favor... Ipod/MP3 integration. CD's are useless on the trail.
PBNJTJ is offline   Reply With Quote Quick reply to this message
Unread 09-21-2009, 11:16 PM   #4
hamilton5
Registered User
2001 WJ 
 
Join Date: Aug 2009
Location: usa
Posts: 444
Quote:
Originally Posted by PBNJTJ View Post
^ Crutchfield.com for sure. Do yourself a favor... Ipod/MP3 integration. CD's are useless on the trail.
lol, a little late cause he already got one but yea welcome to 2010 where our cd players play mp3's and dont skip
hamilton5 is offline   Reply With Quote Quick reply to this message
Unread 09-21-2009, 11:32 PM   #5
CaptainZJ
Registered User
1994 ZJ 
 
Join Date: Sep 2009
Location: Three Rivers
Posts: 34
I was forced to wire my CD deck abnormally because the way Chrysler engineers wired the audio equipment. I've done lots of installs and never seen it where I had to wire it that way. It was weird, I don't remember what it was, I think power antenna, but I had to run the remote turn on into the same crimp.
CaptainZJ is offline   Reply With Quote Quick reply to this message
Unread 09-22-2009, 06:52 PM   #6
PBNJTJ
Registered User
1998 TJ Wrangler 
 
Join Date: Sep 2009
Location: So. Cal., California
Posts: 56
Quote:
Originally Posted by hamilton5 View Post
lol, a little late cause he already got one but yea welcome to 2010 where our cd players play mp3's and dont skip
Hmm you must have a better head unit than I do. Mine plays all sorts of media files including mp3s but it still skips. Then again it is an older unit.
PBNJTJ is offline   Reply With Quote Quick reply to this message
Unread 09-23-2009, 11:01 AM   #7
ECMUDSLINGER
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Outer Banks N.C.
Posts: 91
thanks for all yall's help i ended up getting one from advance auto but i ran into another problem....my speakers were crackling on the passenger side and my drivers haven't worked since i got the thing, then yesterday i ended up with no sound some odd reason? i haven't put in the new CD player yet but i was thinking my speakers are blown or i need new wiring to my speakers, i haven't taken a look at it yet but will do soon.but any suggestions would help before i go buy new wires or speakers..thks ECM
ECMUDSLINGER is offline   Reply With Quote Quick reply to this message
Unread 09-23-2009, 11:14 AM   #8
ZeJokee
Registered User
1993 ZJ 
 
Join Date: Nov 2008
Location: Kansas City, Missouri
Posts: 1,492
My friend got one of those adapters for the radio and it has been nothing but a problem. Worked for about a week then there was no sound. We traced it down the the adapter. I would jsut neatly wire it directly in.
__________________
99 WJ Ltd, Blacked out, 4.7L, 242j Swap, 2'' BB, 245/75/16 Kuhmo Venture AT KL78, Flow Master Super 40, MagnaFlow high flow Cat, Akebono caliper upgrade, Addco rear swaybar, Westin brush guard, Moog Super Trail Boss, Rancho RS5000, Rola roof rack with dual kayak J hooks, PAC-AOEM-CHR, Sony Xplod 1200w amp, 2 Sony Xplod 12'' subs, 118,XXX miles (SOLD)
93 ZJ Ltd, Blacked out, 5.2L, Reman 46RH, Reman 242 Swap, 3.5'' IRO + 2" BB, 33x12.50r15 Mud Claw MTX radials, Bushwacker Flares, 216,XXX miles (Still parked in NC)
04 F-350 SD Crew Cab FX4 Lariat, 6.0 PSD SRW, Head studs, AFE Stage 2 SI Pro Guard 7 intake, Blue Spring mod, 150,XXX Miles

ZeJokee is offline   Reply With Quote Quick reply to this message
Unread 09-23-2009, 11:53 AM   #9
ezflip
NEWS FLASH It snows in MI
 
ezflip's Avatar
2002 WJ 
 
Join Date: Oct 2008
Location: Michigan
Posts: 4,957
Quote:
Originally Posted by PBNJTJ View Post
Hmm you must have a better head unit than I do. Mine plays all sorts of media files including mp3s but it still skips. Then again it is an older unit.
I think he meant our headunits play mp3's via ipods or usb drives and therefor do not skip. It was confusing for him to say cd players.
__________________
~James

2002 Overland - 4.7 HO, "Select-Drive", 4" RC long arms, TAG front winch bumper, 32" BFG KM's, Kolak 3" exhaust, Flowmaster 50 series


Build Thread


The Thanksgiving JF Membership Giveaway is here!!
ezflip is offline   Reply With Quote Quick reply to this message
Unread 09-23-2009, 07:09 PM   #10
tazimafied
Registered User
2000 WJ 
 
Join Date: Jan 2009
Location: Mojave Desert, CA
Posts: 237
Quote:
Originally Posted by ECMUDSLINGER View Post
thanks for all yall's help i ended up getting one from advance auto but i ran into another problem....my speakers were crackling on the passenger side and my drivers haven't worked since i got the thing, then yesterday i ended up with no sound some odd reason? i haven't put in the new CD player yet but i was thinking my speakers are blown or i need new wiring to my speakers, i haven't taken a look at it yet but will do soon.but any suggestions would help before i go buy new wires or speakers..thks ECM
It sounds like you have a bum head unit. Plug in the new unit without completely installing it and see if the speakers work. If they don't, then you can start tracing wires and checking speakers
__________________
Because I felt like it!
tazimafied is offline   Reply With Quote Quick reply to this message
Unread 09-24-2009, 07:30 PM   #11
ECMUDSLINGER
Registered User
1998 ZJ 
 
Join Date: Jan 2009
Location: Outer Banks N.C.
Posts: 91
Quote:
Originally Posted by tazimafied View Post
It sounds like you have a bum head unit. Plug in the new unit without completely installing it and see if the speakers work. If they don't, then you can start tracing wires and checking speakers
Will do thanks alot..ECM
ECMUDSLINGER is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.