Can't figure out the squeak!!! - Page 2 -

LinkBack Thread Tools
post #16 of 16 Old 01-24-2014, 11:14 PM Thread Starter
Registered User
1996 ZJ 
Join Date: Sep 2009
Location: Jax
Posts: 369
i think its honestly the ac compressor. i took the belt off and spun all the pulleys and none of em stuck or grinded except for the ac compressor. I did put in a new lower pulley and im still getting teh squeak and it really sounds like its coming from the compressor. and i paid around $30 for the new belt. i'll the long screwdriver trick to see for sure. i aint really in a hurry to replace the ac compressor seeing as how its winter, but the squealing is really annoying, however once the engine has been running for awhile it dont squeak at all.

Green Jeep #337
R.I.P. Ratmonkey...Your now wheelin with the angels
VolcomPunk is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome