JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   Can anyone help ?? (http://www.jeepforum.com/forum/f13/can-anyone-help-1501515/)

Thatrussokid 03-30-2013 06:05 PM

Can anyone help ??
 
1996 jeep grand cherokee orvis 5.2 v8 tranny is 46rh

So auto zone scanned my jeep an it was throwing governor pressure sensor code didn't draw check engine light tho i only brought it to get scanned cause sometimes if u just started the jeep up an went to drive an go it would just accelerate fast to 40mph then just rev like it was starting in 2nd or 3rd gear so I would have to stop shut off an then put back to drive an it would be ok then a few months later now it won't drive it just revs up wont drive only revers works so I order the sensor an solenoid replaced them put back together an still isn't fixed only will drive if u let it roll an slowly give gas it will start to go but u can't really put ur foot down or it will just rev up fluid is correct level anyone no what else could be?

Please help!! Thanks

belalerede 03-30-2013 06:13 PM

Check your tv cable and the wiring to your transmission if they are good then it would be time to change your sensors in the transmission.

durango-bob 03-30-2013 09:13 PM

Quote:

Originally Posted by Thatrussokid (Post 15220021)

So auto zone scanned my jeep an it was throwing governor pressure sensor code didn't draw check engine light tho i only brought it to get scanned cause sometimes if u just started the jeep up an went to drive an go it would just accelerate fast to 40mph then just rev like it was starting in 2nd or 3rd gear so I would have to stop shut off an then put back to drive an it would be ok then a few months later now it won't drive it just revs up wont drive only revers works so I order the sensor an solenoid replaced them put back together an still isn't fixed only will drive if u let it roll an slowly give gas it will start to go but u can't really put ur foot down or it will just rev up fluid is correct level anyone no what else could be?

Wow, all that in one sentence. I'm impressed.

Thatrussokid 04-01-2013 06:18 PM

I changed out both sensor am solenoid an tv cable fine

Rich93ZJ 04-01-2013 06:45 PM

You should have the 44RE trans not the 46RH. 46RH was up to 1995. Are you sure you installed the correct parts?

Mickey_D 04-01-2013 07:22 PM

Also check/change the transmission filter. If it's at all clogged/restricted the transmission will not shift correctly.

jeepyard 04-01-2013 08:24 PM

sounds like its time for a rebuild or replace for that transmission. Doesnt sound good!

Thatrussokid 04-02-2013 09:53 AM

Yes I switched the correct parts sensor an solenoid also changed filter an gasket still no good think it could be the tps? Or tcm ?

ratmonkey 04-02-2013 10:10 AM

Typical symptoms of a worn out direct drive clutch.


The time now is 02:56 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.