A/C fan doesn't work. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > A/C fan doesn't work.

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits~Artec JK 1 TON SWAP~

Reply
Unread 08-09-2005, 12:45 PM   #1
lizardking
Registered User
 
Join Date: Aug 2005
Posts: 2
A/C fan doesn't work.

Hi. My A/C fan stopped working the other day (figures…I just moved to AZ a week ago). I checked the fuses – there all good. So I guess the motor to shot...right? Is there anything else I should check?

My vehicle is a 98 Jeep Grand Cherokee 4.0

I know the compressor works because the green LED comes on when I press the A/C button, and you can feel it put a load on the engine. Also, this is kind of interesting, when I travel at freeway speeds, a very small amount of cold air comes out. I don’t think it is coming from the fan. It must be coming from outside somehow.

How do I replace the fan? Is it easy? I looked under the dash and noticed something that looked like the backside of a fan motor underneath the dash on the passenger side. Is that it?

Any help anyone could give me would be appreciated. It’s hot out here!

lizardking is offline   Reply With Quote
Unread 08-09-2005, 12:48 PM   #2
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder, CO
Posts: 23,082
Does your heat blow? I am confused if you mean you are blowing warm air or no air is blowing at all?

-Ryan
__________________
'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline   Reply With Quote
Unread 08-09-2005, 01:05 PM   #3
lizardking
Registered User
 
Join Date: Aug 2005
Posts: 2
It works now!

No air was blowing at all. I didn’t test the heat, until just now – I just tried it. The heat fan does work. I then flipped it to A/C and now the A/C is working! Its almost seems like switching it to heat then back to A/C fixed the problem. Hopefully it doesn’t happen again. Thanks.
lizardking is offline   Reply With Quote
Unread 08-09-2005, 08:36 PM   #4
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
Glad it started working for you again. However, it is my experience that problems rarely "fix themselves" for any length of time. Take this opportunity to look around for loose wiring or overheated resistors in the area of the blower. Otherwise, you are just going to be waiting for something to smoke (which can make identification of the problem easier).... Good luck
__________________
Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.