A/C fan doesn't work. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 08-09-2005, 12:45 PM Thread Starter
lizardking
Registered User
 
Join Date: Aug 2005
Posts: 2
A/C fan doesn't work.

Hi. My A/C fan stopped working the other day (figures…I just moved to AZ a week ago). I checked the fuses – there all good. So I guess the motor to shot...right? Is there anything else I should check?

My vehicle is a 98 Jeep Grand Cherokee 4.0

I know the compressor works because the green LED comes on when I press the A/C button, and you can feel it put a load on the engine. Also, this is kind of interesting, when I travel at freeway speeds, a very small amount of cold air comes out. I don’t think it is coming from the fan. It must be coming from outside somehow.

How do I replace the fan? Is it easy? I looked under the dash and noticed something that looked like the backside of a fan motor underneath the dash on the passenger side. Is that it?

Any help anyone could give me would be appreciated. It’s hot out here!

lizardking is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-09-2005, 12:48 PM
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder
Posts: 23,085
Does your heat blow? I am confused if you mean you are blowing warm air or no air is blowing at all?

-Ryan

'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline  
post #3 of 4 Old 08-09-2005, 01:05 PM Thread Starter
lizardking
Registered User
 
Join Date: Aug 2005
Posts: 2
It works now!

No air was blowing at all. I didn’t test the heat, until just now – I just tried it. The heat fan does work. I then flipped it to A/C and now the A/C is working! Its almost seems like switching it to heat then back to A/C fixed the problem. Hopefully it doesn’t happen again. Thanks.
lizardking is offline  
post #4 of 4 Old 08-09-2005, 08:36 PM
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
Glad it started working for you again. However, it is my experience that problems rarely "fix themselves" for any length of time. Take this opportunity to look around for loose wiring or overheated resistors in the area of the blower. Otherwise, you are just going to be waiting for something to smoke (which can make identification of the problem easier).... Good luck

Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
will this work nuey302 ZJ Grand Cherokee Forum 19 12-16-2008 02:36 AM
How does IAC work li'l jeep ZJ Grand Cherokee Forum 10 11-02-2008 08:49 PM
Hmm Would this work deathbylaxitive ZJ Grand Cherokee Forum 6 02-04-2007 12:27 AM
95 ZJ Power Window issues... work.. don't work... slgunnel ZJ Grand Cherokee Forum 7 11-30-2006 04:05 PM
My backup lights don't work or work intermittently. moabster ZJ Grand Cherokee Forum 0 12-23-2002 12:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome