Bucks,Bogs and stalls - cant find the problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Bucks,Bogs and stalls - cant find the problem

The NEW Revolution Gear and Axle from 4LowParts.comTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 09-25-2009, 08:23 PM   #1
steelblue94
Registered User
1994 ZJ 
 
Join Date: Sep 2009
Location: North Jersey
Posts: 2
Bucks,Bogs and stalls - cant find the problem

I need some help, and have try everything. I have a problem with it stalling out for no reason then starting right back up and running fine, sparatic bucks and bogs when given gas. The throttle body, IACV, were cleaned, had a tune up no more than a month ago. I am at a loss.

steelblue94 is offline   Reply With Quote
Unread 09-25-2009, 08:26 PM   #2
MoonyJohn
Mountain Climber
 
MoonyJohn's Avatar
2008 JK Wrangler 
 
Join Date: Feb 2008
Location: West Linn, Oregon
Posts: 6,603
Id seafoam your engine, and gas tank. I did that to mine and my idle is so much better. Not sure if it will fix the starting problem, but i recently fixed my water pump and that fixed my stalling problem i had.
__________________
08 JK Sahara | AEV | Rock Krawler | BFGoodrich | Yukon | ARB | Solid | Bushwacker | Yakima | Rigid Industries

"Water covers 3/4 of the earth, Jeep covers the rest"
MoonyJohn is offline   Reply With Quote
Unread 09-25-2009, 08:40 PM   #3
steelblue94
Registered User
1994 ZJ 
 
Join Date: Sep 2009
Location: North Jersey
Posts: 2
Thanks I'll try the seafoam, But I have already replaced the water pump when I first bought it. I have taken it to my mechanic several time explained and he cant figure out what is wrong.
steelblue94 is offline   Reply With Quote
Unread 09-25-2009, 09:58 PM   #4
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha, NE
Posts: 20,099
I know that I have several spark plug wires that were burnt through. I'm also guessing that I need to replace the plugs and the distributor cap or at least remove and check it out for cross sparking.

Hunter
__________________
00 4.7 Laredo...stock

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.3661
Texas ZJ1 is offline   Reply With Quote
Unread 09-25-2009, 10:13 PM   #5
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,805
Unhook your o2 sensor and see what happens.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.