break noise - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 05-06-2004, 01:54 PM Thread Starter
sacto-zj
Registered User
 
Join Date: Apr 2004
Location: sacramento ,ca
Posts: 19
break noise

this has been going on for aboue 4 months but just recently it started to get worse.... When I'm going below 10 or 15 mph for a long period of time *lets say in trafic* or when i'm just lightly tounching the break peddle for a distance *lets say to slow down for a stop light* I get this loud humming noise coming from the break peddle... the peddle also goes very stiff and vibrates slightly kinda like abs is engadging. This usualy goes away by me pressing on the peddle hard or by speeding up. Oh and the break light will SOMETIMES come on when it does this. I've checked my fluid levels and I blead the breaks not too long ago... any ideas?


93 limited 5.2L, BB lift, 31x10.5, flow master.
famous last words "yeah sure you can make it through that.... oooops nevemind..."
sacto-zj is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-06-2004, 09:50 PM
Buddha_Kip
Registered User
 
Buddha_Kip's Avatar
2000 WJ 
 
Join Date: Aug 2003
Location: N'awlins
Posts: 1,098
uummmmm.........

you may want to check your pads. the "humming" noise is most probably the wear sensor rubbing on the rotor.

2000 WJ Limited - 2.5" Rusty's springs WAAG 1-piece front brush guard custom built WAAG nerf bars PIAA 580 lighting Custom Paint One-off Aluminum Treadplate Door Entry Guards & Rear Bumper Step
1986.5 Porsche 928S - 18" Moda MD1 Autothority Chips Rear Muffler Bypass Short-Shift Kit
Grease Monkey & HNIC @ Clasik Auto
Buddha_Kip is offline  
post #3 of 4 Old 05-07-2004, 11:19 AM Thread Starter
sacto-zj
Registered User
 
Join Date: Apr 2004
Location: sacramento ,ca
Posts: 19
Quote:
Originally Posted by Buddha_Kip
uummmmm.........

you may want to check your pads. the "humming" noise is most probably the wear sensor rubbing on the rotor.
no it wasn't the pads... it was almost like fart sound for lack of a better word. Plus the peddle geting stiff and vibrating wouldin't be cuased by that... but i pulled my abs fuse last night to c if that had neithing to do with it, and it seemed to fix it... so i'm thinking its prolly one of my speed sensors. So i guess fornow i'll just live with no abs.

93 limited 5.2L, BB lift, 31x10.5, flow master.
famous last words "yeah sure you can make it through that.... oooops nevemind..."
sacto-zj is offline  
post #4 of 4 Old 05-07-2004, 11:58 AM Thread Starter
sacto-zj
Registered User
 
Join Date: Apr 2004
Location: sacramento ,ca
Posts: 19
Quote:
Originally Posted by Buddha_Kip
uummmmm.........

you may want to check your pads. the "humming" noise is most probably the wear sensor rubbing on the rotor.
no it wasn't the pads... it was almost like fart sound for lack of a better word. Plus the peddle geting stiff and vibrating wouldin't be cuased by that... but i pulled my abs fuse last night to c if that had neithing to do with it, and it seemed to fix it... so i'm thinking its prolly one of my speed sensors. So i guess fornow i'll just live with no abs.

93 limited 5.2L, BB lift, 31x10.5, flow master.
famous last words "yeah sure you can make it through that.... oooops nevemind..."
sacto-zj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
What did I break? Jubei ZJ Grand Cherokee Forum 2 01-11-2009 05:51 PM
Break in for our new CRD WK Weissbrewer WK Grand Cherokee & XK Commander Forum 18 07-13-2008 12:42 PM
Rear Axle/break noise and grind HELP bobsworld5 ZJ Grand Cherokee Forum 2 10-20-2006 12:34 PM
Break Noise lambar ZJ Grand Cherokee Forum 3 06-05-2006 06:49 AM
not did I break, What did I break? (help) soccer_jim ZJ Grand Cherokee Forum 11 12-12-2003 12:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome