body control module - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > body control module

Huge Soft top SaleRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!

Reply
Unread 06-27-2004, 02:49 PM   #1
buzzbomb
Registered User
 
Join Date: Oct 2002
Posts: 51
body control module

We have a 96 Grand Cherokee Limited with some weird electrical problems. Does anybody know where the body control module is located and how much they cost?
Thanks.

buzzbomb is offline   Reply With Quote Quick reply to this message
Unread 06-29-2004, 08:14 AM   #2
jane8888
Registered User
 
Join Date: Jun 2004
Posts: 17
I'm not sure where it is in the 96. In my 2000, it's attached to the junction block, under the driver's side of the instrument panel.

Mine is being replaced by the dealer (humph) and was 500 bucks.
jane8888 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2004, 09:34 AM   #3
buzzbomb
Registered User
 
Join Date: Oct 2002
Posts: 51
Thanks for the info, what symptoms did you have?
buzzbomb is offline   Reply With Quote Quick reply to this message
Unread 06-29-2004, 01:20 PM   #4
jane8888
Registered User
 
Join Date: Jun 2004
Posts: 17
Quote:
Originally Posted by buzzbomb
Thanks for the info, what symptoms did you have?
Well....

it all started with my keyless/sentry light coming on. Then, the CD changer wouldn't work (every once in awhile). Then, the passenger side window wouldn't roll down. Then, all hell broke loose. Every warning light came on, no windows would work, remote was useless. The rearview mirror grinding constantly trying to turn the mirror every whichaway.

I could disconnect my battery, and all would work well for a few hours, but symptoms would soon return. I thought my Jeep was possessed.

I tried various things to fix it...changed the ignition switch when I read similar symptoms came when that went out. Didn't change a thing.

I gave in and have let the dealership have it. Hopefully, they are correct in their diagnosis that it's the BCM.

I just called them; the part is in and they are now putting it in. I'll keep you posted if you wish...especially my grand total.

Later....
jane8888 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2004, 02:06 PM   #5
jane8888
Registered User
 
Join Date: Jun 2004
Posts: 17
Dealership just called. The new BCM fixed what ailed my Jeep. 825 dollars.
jane8888 is offline   Reply With Quote Quick reply to this message
Unread 06-29-2004, 02:51 PM   #6
buzzbomb
Registered User
 
Join Date: Oct 2002
Posts: 51
Ouch, glad it got fixed. I guess I'll be doing one soon.
buzzbomb is offline   Reply With Quote Quick reply to this message
Unread 06-29-2004, 05:43 PM   #7
jane8888
Registered User
 
Join Date: Jun 2004
Posts: 17
I'm glad to get it back working just fine. Just a note, 409 bucks labor and 338 for the part.
jane8888 is offline   Reply With Quote Quick reply to this message
Unread 06-30-2004, 02:24 AM   #8
Colorado 5.9
Registered User
1998 ZJ 
 
Join Date: Dec 2001
Location: Denver, Colorado
Posts: 2,049
Quote:
Originally Posted by jane8888
Dealership just called. The new BCM fixed what ailed my Jeep. 825 dollars.
I hope that's what it really was. I've heard people with the same problems & all's it turned out to be was a bad Battery.
__________________
ZJ 98 5.9 LTD. Lots of mods. 7" T&T's Long Arm Lift ,BFG KM2"s,35X12.50x16's,4:56's, Vanco brake upgrade, M1intake,Holley52mmTB,MikeLeach Headers,, Arb'ed HP D30,Aussie Locked rear,Procomp MX6 Shocks,Arb front,RearTR bumpers,ECT.ECT.

Latest Pics
Colorado 5.9 is offline   Reply With Quote Quick reply to this message
Unread 06-30-2004, 08:00 AM   #9
jane8888
Registered User
 
Join Date: Jun 2004
Posts: 17
Quote:
Originally Posted by Colorado 5.9
I hope that's what it really was. I've heard people with the same problems & all's it turned out to be was a bad Battery.
Yea,

The first thing I replaced when those symptoms arose was the battery. That wasn't it.
jane8888 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.