Blinker problem - JeepForum.com

 
LinkBack Thread Tools
post #1 of 13 Old 04-28-2013, 04:08 PM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
Blinker problem

Yesterday I set the alarm on the ZJ off and tried to turn it off with the remote but it was missing a battery so I popped the hood and pulled the horn fuse. Then went in the house to get new batteries and then turned it off. I plugged the horn fuse back in and now my blinkers and my info counsel dont work. I found a blown fuse so I replaced it and once again it blew any thoughts help anything thanks


98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 04-29-2013, 06:15 AM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
Bump

98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
post #3 of 13 Old 04-29-2013, 08:39 AM
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Do you mean horn "relay"...? Problems all started with pulling/installing the relay?

Junction Block Fuse#6 supplies power to turn/hazard flasher, VIC, NSS, day/night mirror.

Disconnect the battery NEG cable, grab an ohmmeter and isolate the short. Seems unrelated to pulling the horn relay.
KoreaZJ is offline  
post #4 of 13 Old 04-29-2013, 11:48 AM
ROFLwaffles
Registered User
1998 ZJ 
 
Join Date: Mar 2013
Location: University Place
Posts: 198
Garage
It's probably low on fluid.

ROFLwaffles is offline  
post #5 of 13 Old 04-29-2013, 04:18 PM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,302
Great stuff, long lasting and won't freeze in the summer.

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.366
Texas ZJ1 is offline  
post #6 of 13 Old 05-02-2013, 05:08 AM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
To funny guys. I found it was the relay nut now it won't start in park so I'm assuming my neutral safety switch is bad since it ing starts in neutral. Any thoughts???????

98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
post #7 of 13 Old 09-11-2013, 02:06 PM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
OK I'm still having blinker issues. while my blinkers some times work it would also only start in neutral so that lead me to believe that the neutral safety switch was bad so I replaced that and now it starts in park like it should but now my blinkers only work when I turn the hazards on and off then they work im totally lost please help. Also the overhead console don't work anymore. the fuse is good I've checked that.

98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
post #8 of 13 Old 09-11-2013, 03:10 PM
eagsc7
Registered User
1994 ZJ 
 
Join Date: Apr 2013
Location: Sweetwater Cyt
Posts: 433
Quote:
Originally Posted by TitletownZJ View Post
OK I'm still having blinker issues. while my blinkers some times work it would also only start in neutral so that lead me to believe that the neutral safety switch was bad so I replaced that and now it starts in park like it should but now my blinkers only work when I turn the hazards on and off then they work im totally lost please help. Also the overhead console don't work anymore. the fuse is good I've checked that.
Yeah, your low on 'blinker' fluid. Lol

My Build Thread: http://www.jeepforum.com/forum/f13/steaks-zj-build-repair-thread-1552698/
eagsc7 is offline  
post #9 of 13 Old 09-11-2013, 03:51 PM
Kingr98
Registered User
1998 ZJ 
 
Join Date: Dec 2012
Location: Madison
Posts: 472
Isn't there a blinker relay behind the passenger's kick panel? Could that be going bad?

I don't have my field service manual with me to check right now.
Kingr98 is offline  
post #10 of 13 Old 09-17-2013, 08:35 AM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
Quote:
Originally Posted by Kingr98 View Post
Isn't there a blinker relay behind the passenger's kick panel? Could that be going bad?

I don't have my field service manual with me to check right now.

I replaced it with a brand new one and still nothing.


Hahaha Blinker fluid that so FREAKIN FUNNY if your not going try helping then Shut up!!!!!!!!!!!!!!!!!!

98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
post #11 of 13 Old 09-17-2013, 08:54 AM
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 2,032
IMS there are separate flasher modules for the hazards and turn signals. If your hazards work then you probably have good wiring after the flasher. I don't remember where the hazard flasher is but my turn signal flasher is above my pedals. Of course mine is a 93 so that may not matter to your 98. A wiring diagram should tell you where the flasher gets power, most likely the multi function switch, and you can start tracing from there.

What have you done to try and diagnose your problem?

EDIT: When you turn the turn signal on does the light come on and not flash or do you get nothing at all?
zjosh93 is offline  
post #12 of 13 Old 09-18-2013, 02:34 PM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
Quote:
Originally Posted by zjosh93 View Post
EDIT: When you turn the turn signal on does the light come on and not flash or do you get nothing at all?
I get noting at all when I try to turn them on

98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
post #13 of 13 Old 09-22-2013, 01:37 PM Thread Starter
TitletownZJ
Registered User
1998 XJ Cherokee 
 
Join Date: Aug 2011
Location: Green Bay
Posts: 250
Well I got the blinkers finally working. I cleaned the contacts in the multi function switch and replaced the fuses and bingo we for blinkers

98 XJ
98 ZJ

Member of Titletown Jeepers
TitletownZJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome