Bad timing and water pump - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 06-18-2013, 08:46 PM Thread Starter
ffjhouse
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2012
Location: Denver
Posts: 17
Bad timing and water pump

So after thinking I had a bad head gasket I tore apart my motor and found a hole in piston #1, I got everything back together and went to fill my cooling system and I noticed that it was dropping again several times. I got under the motor and looked and found a leak that was coming from the oil seal area, I read somewhere that it could be a leak coming from the hole from a bad water pump, can anyone give input into this? And would it be easier to take the head off again to fix the timing or try and do it all from the timing chain area?

ffjhouse is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome