bad pcm? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > bad pcm?

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 02-09-2013, 11:43 AM   #1
richh789
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2013
Location: myrtle beach, sc
Posts: 131
bad pcm?

I was having no start problem. I had spark and fuel. Changed cap do to the fact that it was worn. Checked fueses, swapped relays.

Finally got it to start after changing plugs (po installed ones that had totally different reach)
Runs for 15 seconds and dies. Once or twice I gotta start the second time but it with idle really rough and die.

Other times it will crank and sound like there's nothing going on at all as if the coil is disconnected. I had originally stand it and the only thing that came up with a code for the fuel pump relay which I had taken out to clear out cylinders.

Now the check engine light is on but I need to borrow a scanner. I've tried locking and unlocking the doors, and I have the key fob which has no alarm just door locks. Any suggestions?

A few days ago when I was trying it the right side bank was flooding with fuel, when I check the compression it was literally come out of the tester after. Now it's not flooding, but still won't run.

richh789 is offline   Reply With Quote Quick reply to this message
Unread 02-09-2013, 11:56 AM   #2
richh789
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2013
Location: myrtle beach, sc
Posts: 131
98 5.2 fyi
richh789 is offline   Reply With Quote Quick reply to this message
Unread 02-09-2013, 12:07 PM   #3
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,591
wiggle connectors on pcm while someone is trying to start it
ZeeJay1997 is online now   Reply With Quote Quick reply to this message
Unread 02-09-2013, 12:14 PM   #4
richh789
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2013
Location: myrtle beach, sc
Posts: 131
The clips that hold plug on are broken off, which leads me to believe there was a previous issue. I was kind of expecting there to be some sort of problems, because the previous owner treated me straight up for a 95 Wrangler that wasn't very nice
richh789 is offline   Reply With Quote Quick reply to this message
Unread 02-09-2013, 12:19 PM   #5
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,591
click on green link below and read #1
ZeeJay1997 is online now   Reply With Quote Quick reply to this message
Unread 02-09-2013, 12:29 PM   #6
richh789
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2013
Location: myrtle beach, sc
Posts: 131
No green link, I'm using app. Maybe need to try pc
richh789 is offline   Reply With Quote Quick reply to this message
Unread 02-10-2013, 05:53 PM   #7
richh789
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2013
Location: myrtle beach, sc
Posts: 131
Turned out to be a relay. Figured it out by pushing on them (for leverage) while tapping on pcm. Dies when I push on it. Was the relay towards the rear drivers side.
richh789 is offline   Reply With Quote Quick reply to this message
Unread 02-10-2013, 06:08 PM   #8
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,591
Glad you figured it out.

Chock one up for the dirty dozen
ZeeJay1997 is online now   Reply With Quote Quick reply to this message
Unread 02-10-2013, 06:13 PM   #9
richh789
Registered User
1987 YJ Wrangler 
 
Join Date: Jan 2013
Location: myrtle beach, sc
Posts: 131
Thanks very much
richh789 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.