Bad alternator causing Transmission code? - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Bad alternator causing Transmission code?

August special - FREE XJ Unibody stiffeners when you buy a~Artec JK 1 TON SWAP~Dan's Old as Dirt Birthday Sale!

Reply
Unread 06-26-2013, 09:17 AM   #16
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee, Wisconsin
Posts: 763
Quote:
Originally Posted by exmilitary View Post
Did you try charging the battery up first to see if the truck shifts out of first gear?
Solenoids and electronics act funny when the voltage is to low.
I agree with the other poster here; check the battery sensor.
Thanks...I put in a new battery and alternator last night...so where is the battery sensor on the 5.9L? I never heard of that.

__________________
2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline   Reply With Quote
Unread 06-26-2013, 11:04 AM   #17
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee, Wisconsin
Posts: 763
Update

Hey guys...mechanic said the PCM is fried.
I just ordered a new one...should be here by Friday.
I'll keep you all posted...and thank you to everyone for ALL your help and advice. I just hope this does the trick!
__________________
2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline   Reply With Quote
Unread 06-26-2013, 11:19 AM   #18
98ZJOKC
Registered User
 
Join Date: Jun 2013
Location: Oklahoma City, OK
Posts: 48
Quote:
Originally Posted by brewcity1 View Post
where is the battery sensor on the 5.9L?
Bottom of the battery tray - have to remove battery to see it. That's one of the reasons I mentioned it as suspect because you had recently had the battery replaced and it might have been damaged or been disconnected.
98ZJOKC is offline   Reply With Quote
Unread 06-26-2013, 11:32 AM   #19
zjosh93
Registered User
1993 ZJ 
 
Join Date: Aug 2010
Location: Austin
Posts: 1,086
If you just had your cat replaced did they weld it in? Welding on the exhaust without disconnecting the battery can fry the PCM.
zjosh93 is offline   Reply With Quote
Unread 06-26-2013, 12:07 PM   #20
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee, Wisconsin
Posts: 763
Quote:
Originally Posted by zjosh93 View Post
If you just had your cat replaced did they weld it in? Welding on the exhaust without disconnecting the battery can fry the PCM.
OHHHH NOOOOOOOOO!!! Yep...just had my cat and muffler replaced. They did weld the new one on...thats gotta be it! They fried the PCM by not disconnecting the battery!
__________________
2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline   Reply With Quote
Unread 06-26-2013, 02:51 PM   #21
exmilitary
Registered User
1998 ZJ 
 
Join Date: Jun 2013
Location: Toronto, Ontario
Posts: 58
Quote:
Originally Posted by brewcity1 View Post
Hey guys...mechanic said the PCM is fried.
I just ordered a new one...should be here by Friday.
I'll keep you all posted...and thank you to everyone for ALL your help and advice. I just hope this does the trick!
Sorry to hear that. I hope the new one works. Did I read that right that someone welded the cat without disconnecting the battery?
Any good welder knows better then that.
I know the pcms can cost a lot of money
If it is not to late, I whould go back and give the guy s**t for this. .
exmilitary is offline   Reply With Quote
Unread 06-26-2013, 02:58 PM   #22
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee, Wisconsin
Posts: 763
Quote:
Originally Posted by exmilitary View Post
Sorry to hear that. I hope the new one works. Did I read that right that someone welded the cat without disconnecting the battery?
Any good welder knows better then that.
I know the pcms can cost a lot of money
If it is not to late, I whould go back and give the guy s**t for this. .
I am actually really thinking about that! They are a great muffler shop, and I have taken my previous Jeeps there without any issues...but this time its costing me a lot in time, money, and sanity!
I actually found a PCM for $235 shipped...so its not too too bad. Better than the $600-$800 the dealerships across the country want if they have it on hand.
I just hope that this fixes everything! I'll let you all know.
__________________
2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline   Reply With Quote
Unread 06-27-2013, 03:00 PM   #23
exmilitary
Registered User
1998 ZJ 
 
Join Date: Jun 2013
Location: Toronto, Ontario
Posts: 58
Quote:
Originally Posted by brewcity1 View Post
I am actually really thinking about that! They are a great muffler shop, and I have taken my previous Jeeps there without any issues...but this time its costing me a lot in time, money, and sanity!
I actually found a PCM for $235 shipped...so its not too too bad. Better than the $600-$800 the dealerships across the country want if they have it on hand.
I just hope that this fixes everything! I'll let you all know.
That's a good deal for a pcm. Up here they are more then 800.00 dollars. Keep me posted. Pm me if you want.
exmilitary is offline   Reply With Quote
Unread 06-27-2013, 03:08 PM   #24
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee, Wisconsin
Posts: 763
Quote:
Originally Posted by exmilitary View Post
That's a good deal for a pcm. Up here they are more then 800.00 dollars. Keep me posted. Pm me if you want.
Yeah...the one from the dealership was $795.
I will definitely keep you posted on whether or not this fixes my issues.
Thanks for all the help!
__________________
2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline   Reply With Quote
Unread 07-02-2013, 08:04 PM   #25
brewcity1
Registered User
2004 WJ 
 
Join Date: Nov 2008
Location: Milwaukee, Wisconsin
Posts: 763
Update

Hey guys...got my 9er back today. All is good!
The new PCM fixed the issues...voltage back at center...fired right up...ran very strong all the way home!
Just wanted everyone that helped out to know what fixed the issues.
Thanks to everyone for ALL the help.
__________________
2004 Grand Cherokee Limited 4.7L
General Grabber AT2's 255/65/17
1" Addco rear sway bar
brewcity1 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.