backup lights not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > backup lights not working

Savvy Aluminum Gas Tank SkidFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Stainless Steel Door Hinge Pins

Reply
Unread 11-25-2002, 12:48 AM   #1
krazypolishboy
Registered User
 
Join Date: Nov 2002
Posts: 4
backup lights not working

my problem is that my backup lights dont work. i replaced both of the tailight back-up bulbs and it still doesnt work. my local pep-boys said they could take a look at it, but if they need to do an electrical system test it would cost about $75. it would really help if i could just fix this myself rather than spending $75. any ideas? thanks alot

krazypolishboy is offline   Reply With Quote
Unread 11-25-2002, 01:50 AM   #2
Ryan2son
Registered User
 
Join Date: Nov 2002
Location: Denver, CO
Posts: 133
Chase your electrical system with a volt meter

See if you have power at the bulb receptical. Next, check for power at the switch. In other words, start from the end source and trace it back....

Richard
__________________
Richard

1999 Jeep Grand Cherokee Laredo
4x4, 4.7 V8, Quadratrac II, Loaded

A Hail the Mighty Philadelphia Eagles!
Ryan2son is offline   Reply With Quote
Unread 11-27-2002, 02:36 PM   #3
madmanfrommars
Registered User
 
Join Date: Oct 2002
Location: Long Island, NY
Posts: 646
I have a problem on my 94 GC where the brake light connection is loose, so sometimes it will work, and sometimes no. I've looked around but I'm not sure if I can fix it so I might have to (GASP) bring it to someone
madmanfrommars is offline   Reply With Quote
Unread 11-28-2002, 09:13 AM   #4
GrandZJ
Registered User
 
Join Date: Nov 2002
Location: Garland TX
Posts: 16
I had the same prob on my 93 and it was the reverse switch on the tranny. Took it apart and cleaned it and has been fine since.

Shawn
GrandZJ is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.