Audio Help! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Audio Help!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank Skid

Reply
Unread 06-28-2013, 05:21 PM   #1
RaevynCarrion
Registered User
1996 ZJ 
 
Join Date: Jul 2012
Location: East Hampton, CT
Posts: 199
Could somebody please get me the wiring harness diagram for a 96 ZJ stereo connector?

RaevynCarrion is offline   Reply With Quote
Unread 06-28-2013, 10:46 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,386
Infinity?
ZeeJay1997 is offline   Reply With Quote
Unread 06-28-2013, 10:53 PM   #3
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,386
i think they are all the same.
sorry, website wont upload files, doing maintenance.
ZeeJay1997 is offline   Reply With Quote
Unread 06-29-2013, 04:23 AM   #4
RaevynCarrion
Registered User
1996 ZJ 
 
Join Date: Jul 2012
Location: East Hampton, CT
Posts: 199
I don't know if it ever had the Infinity, I bought it used with a custom job installed. But the factory wiring harness is still there.
RaevynCarrion is offline   Reply With Quote
Unread 06-29-2013, 01:11 PM   #5
chalkboard
Registered User
1997 ZJ 
 
Join Date: May 2013
Location: SoCal, CA
Posts: 60
I have been working on the oem radio in my '97. I googled for a schematic and was unable to find one exactly like mine (non-infinity.) What I did find after much reading is that though the pin locations found in many diagrams didn't match my harness plugs, the color codes are fairly consistent. I used a meter to check for resistance (4 ohms, I believe) to find speaker pin locations and test wiring for shorts, easier than chasing wires. I have forgotten whether it is the front or the rear, but one pair has the positive lead in one plug and the negative in the other.

I, too, would like to have an actual schematic for my non-infinity setup.
__________________
1997 ZJ 4.0/154k/stock
2001 WJ 4.7/65k/stock
chalkboard is online now   Reply With Quote
Unread 06-29-2013, 02:51 PM   #6
greyhnd
Registered User
1996 ZJ 
 
Join Date: Nov 2011
Location: Huntingburg, IN
Posts: 303
Go here.......www.installdr.com. Just do a search for your model and you'll find detailed write ups for installation and wiring. Many people here have used that site for help.
greyhnd is offline   Reply With Quote
Unread 06-30-2013, 07:56 AM   #7
RaevynCarrion
Registered User
1996 ZJ 
 
Join Date: Jul 2012
Location: East Hampton, CT
Posts: 199
Thanks for the advice, everyone. I ended up doing a search on JF and found the right image for my ZJ. It turns out I blew out a bass block in one of my crossovers, so I had to disconnect my tweeters. Sacrificed my high end, butt least I can listen to music now.
RaevynCarrion is offline   Reply With Quote
Unread 06-30-2013, 05:24 PM   #8
Jenglish
Registered User
1998 ZJ 
 
Join Date: Jun 2012
Location: Raleigh, Nc
Posts: 26
Yea nothing like the popping when the infinity's are blown.
Jenglish is offline   Reply With Quote
Unread 06-30-2013, 05:27 PM   #9
ngould1
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Columbus, OH
Posts: 50
This should help!

http://crutchfield.custhelp.com/app/...dRTXRDaw%3D%3D
ngould1 is offline   Reply With Quote
Unread 07-07-2013, 05:30 AM   #10
RaevynCarrion
Registered User
1996 ZJ 
 
Join Date: Jul 2012
Location: East Hampton, CT
Posts: 199
That definitely helped, but unfortunately since locating the problem I've corrected it and bought new crossovers...I apparently blew mine out some how. However, the same issue popped up, and I apparently can't run tweeters through my driver side door. Is there a wire connection for tweeters under the forward/top dash panel where it looks like you're meant to mount them in those empty vents? I may try wiring through there before I give up entirely.
RaevynCarrion is offline   Reply With Quote
Unread 07-07-2013, 08:06 AM   #11
coralman
green backs to no backs
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 4,322
radio-base.jpg
radio-premium.jpg

If you originally had the base system the wires should be under the panel unless the previous owner did something with them on the new system install. Unfortunately, even if there they dead end into the connector block adjacent to the BCM. Connectors C351 and C307 as seen in the diagram. They are parralell{?} to the full size speakers.

Since the new install of the system before you bought it it will be difficult to troubleshoot from here. Sounds like almost that the system is pumping too much power and blowing the crossovers. But thats just a guess.In my laredo I just ran two wires parralell to each door spreaker at the radio to supply the instument panel speakers.

The upper pic is of a base system without a amp.
__________________
Move over bear.I'm tired of working on the jeep

Links to axle rebuilds, mount replace,a/c box rebuild,ect in history section of my profile page
coralman is offline   Reply With Quote
Unread 08-22-2013, 06:43 PM   #12
RaevynCarrion
Registered User
1996 ZJ 
 
Join Date: Jul 2012
Location: East Hampton, CT
Posts: 199
Got it all figured out guys, thanks for the help. The issue was being cause by a feedback loop due to the tweeters in my 2-way door speakers. Ripped em out and stuck some 300W Pyle mids in the front door, whole new Pyle component setup in the back, and she's all good. Sounds ten times better, too.
RaevynCarrion is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.