All Power Windows Don't Work?????? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > All Power Windows Don't Work??????

TeraFlex Now at Rockridge 4WD! BEST DEALS around!Alloy usa heavy duty ball joint kitsENGO QUADLUX 6" to 54" LED AMBER AND WHITE MULTI

Reply
Unread 12-16-2003, 04:57 PM   #1
Clay454
Registered User
 
Join Date: Dec 2003
Location: Louisville Kentucky
Posts: 5
All Power Windows Don't Work??????

I have a 1995 Grand Cherokee Orvis. All four power windows have stopped working. No Up! No Down. Checked fuses, checked the controll cluster.

I have seen this problem all over the internet, but nobody seems to know what the problem is.

Anybody in here have any clues?

Rg3ecom@aol.com
Clay454

Clay454 is offline   Reply With Quote Quick reply to this message
Unread 12-16-2003, 05:33 PM   #2
Stocker
Registered User
 
Join Date: Nov 2002
Location: Jefferson State
Posts: 814
Welcome to the boards!

Take a look at the wiring harness connector in the driver's door jamb. Pull back the rubber boot and look for broken wires or corroded connections. Common problem area. Also make sure the torx screw that holds the connector together is snug. Good luck!
__________________
1995 5.2 ZJ Sold... but still in the family
Stocker
Stocker is offline   Reply With Quote Quick reply to this message
Unread 12-17-2003, 04:27 PM   #3
Clay454
Registered User
 
Join Date: Dec 2003
Location: Louisville Kentucky
Posts: 5
Thanks Stocker...

There are two completely cut wires and two shredding wires inside the boot.

I will let you know how it turns out when I splice it all back together this weekend!

Peace

Clay
Clay454 is offline   Reply With Quote Quick reply to this message
Unread 12-17-2003, 07:13 PM   #4
Stocker
Registered User
 
Join Date: Nov 2002
Location: Jefferson State
Posts: 814
__________________
1995 5.2 ZJ Sold... but still in the family
Stocker
Stocker is offline   Reply With Quote Quick reply to this message
Unread 12-20-2003, 09:04 AM   #5
Clay454
Registered User
 
Join Date: Dec 2003
Location: Louisville Kentucky
Posts: 5
Thanks! I have power windows again.

A black wire and a red wire ironically were completely broken.
Although it was 30 degrees outside, it only took a grueling seven minutes to fix!

Thanks Again!
Clay454
Clay454 is offline   Reply With Quote Quick reply to this message
Unread 12-26-2003, 11:46 AM   #6
unreal33
Registered User
 
Join Date: Apr 2002
Posts: 17
I'm having the same problem w/ my 93 ZJ.. my fuse are good, but my wires are also not cut.. there are two wires how ever that are split but still connected I believe a black wire w/ white stripe and a red wire w/ a black stripe.. could my driver side switch be gone?

* also oddly enough I do have one solid black wire (coming from the door) thats been cut.. but there isn't another wire on the oposite side to meet up w/ it.. think this is related?
unreal33 is offline   Reply With Quote Quick reply to this message
Unread 12-26-2003, 12:13 PM   #7
Clay454
Registered User
 
Join Date: Dec 2003
Location: Louisville Kentucky
Posts: 5
Pardon the expression, but my problem seemed pretty clear cut.

Pardon the expression, but my problem seemed pretty clear cut.

I would bet that the black wire is a ground. You may get partial power even if this wire is cut.

I had to cut back the black rubber boot between the door and the door-jam to get to the cut wires. It's pretty tight, but I would go ahead and splice everything back together and see what happens.

Let me know how it goes!

Peace!

Clay454
Clay454 is offline   Reply With Quote Quick reply to this message
Unread 12-26-2003, 12:35 PM   #8
unreal33
Registered User
 
Join Date: Apr 2002
Posts: 17
well what am I splicing the black wire to? there isn't any thing else in there to conect it to! lol
unreal33 is offline   Reply With Quote Quick reply to this message
Unread 12-26-2003, 01:31 PM   #9
Aryding
Registered User
 
Join Date: Dec 2003
Posts: 8
Power Windows in Rear not working

My '93 also is having a problem such as yours, but the funny thing is that I tested the connection and its good. So now I have no idea what to do
Aryding is offline   Reply With Quote Quick reply to this message
Unread 12-26-2003, 03:48 PM   #10
Swamp Boy
Registered User
1993 ZJ 
 
Join Date: Jan 2003
Location: New Orleans
Posts: 1,327
Check the power in the drivers switches and if you have power there take off the passenger door skin and check there..
IF you dont have power there then follow the wires till you find the short..

BUt start in the drivers door ( door jamb is the usual culprit..)

Pull on each wire individually ..(this may take some time.) Dont pull hard just hard enough to tell if the wire is broken but still inside the rubber coating.. Opening and closing of the door could have broken a wire...


Oh yeah.. Dont want to forget ... Welcome to the board..
__________________
Just another soccer moms Grocery getter....
[Url]http://www.jeepforum.com/gallery/files//8/5/6/5/hatt034.jpg[/url]
Swamp Boy is offline   Reply With Quote Quick reply to this message
Unread 12-27-2003, 02:50 PM   #11
Aryding
Registered User
 
Join Date: Dec 2003
Posts: 8
Stupid Back Windows

Well it looks like from the drivers side I can put up the front windows but not the back ones. I can also lock all the doors. I found that by checking the connections the back doors were getting their 12 volts, so I'm pretty sure there is no cut wires. the only BUTTONS that don't work are the back doors and the drivers side for the back door windows. But the thing is is that the connection is getting its 12 volts. I have no idea now what to do so any tips would be nice, the car goes outside in the pouring rain in a couple days.
Aryding is offline   Reply With Quote Quick reply to this message
Unread 12-27-2003, 04:51 PM   #12
Aryding
Registered User
 
Join Date: Dec 2003
Posts: 8
Well now I notice that locking the doors can only happen when the car is not on "acc" but when it is it only unlocks. Maybe if I start up the car the when I get it all back together I'll be able to put the windows up... ;(
Aryding is offline   Reply With Quote Quick reply to this message
Unread 12-30-2003, 08:32 PM   #13
Aryding
Registered User
 
Join Date: Dec 2003
Posts: 8
Well I got them up just in time, I jumped the back doors and they went up!!! So now I'm pretty sure it's the switchs that are faulty and I'm going to call Jeep tomorrow and by some new ones.
Aryding is offline   Reply With Quote Quick reply to this message
Unread 12-31-2003, 04:15 AM   #14
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
Quote:
Originally Posted by Aryding
Well I got them up just in time, I jumped the back doors and they went up!!! So now I'm pretty sure it's the switchs that are faulty and I'm going to call Jeep tomorrow and by some new ones.
Before spending money on new switches, have you tried taking them apart and cleaning the contacts? Momentary contacts like these often make a spark that will scorch the contact surface. Disassembly and a little bit of emery cloth will fix 'em right up.
__________________
Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.