After market radio - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > After market radio

Jeep Grand Cherokee Headlight AssembliesJeep Wrangler Wheel Bearing & Hub - FrontPremium LED Lighting by VISION X, Proudly sold at ROCKRIDG

Reply
Unread 09-24-2012, 08:56 AM   #1
rob84044
Registered User
 
Join Date: Mar 2012
Location: fredericksburg, va
Posts: 13
After market radio

There is an alectrical issue I believe with my radio.

The errorr I keep on recieving is miswiring chk wiring then reset radio.

And every time I reset my radio (remove the negative plug from the battery) the radio will trun back on...

Oh and also after about an hour the radio will go back off again.

Does anyone know why this is happening?

rob84044 is offline   Reply With Quote
Unread 09-24-2012, 09:53 AM   #2
RagTagSoldier
Registered User
1996 ZJ 
 
Join Date: Nov 2011
Location: bellefontaine, ohio
Posts: 683
Had a problem like this a while back, turned out the actual plug on the back was defective, got a new one, wired it up. Haven't had a problem since.

Just my .02

Sent from my iPhone using JeepForum
RagTagSoldier is offline   Reply With Quote
Unread 09-24-2012, 09:55 AM   #3
xDJxJUSTx
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Posts: 133
What type of radio is it?
xDJxJUSTx is offline   Reply With Quote
Unread 09-24-2012, 10:03 AM   #4
RagTagSoldier
Registered User
1996 ZJ 
 
Join Date: Nov 2011
Location: bellefontaine, ohio
Posts: 683
Mine is a dual, might nt be your model but you never know what slipped by quality control. I can get my model number for you when I go on break

Sent from my iPhone using JeepForum
RagTagSoldier is offline   Reply With Quote
Unread 09-24-2012, 10:18 AM   #5
xDJxJUSTx
Registered User
1997 ZJ 
 
Join Date: Jun 2012
Posts: 133
Quote:
Originally Posted by RagTagSoldier View Post
Mine is a dual, might nt be your model but you never know what slipped by quality control. I can get my model number for you when I go on break

Sent from my iPhone using JeepForum
Sorry, I meant rob84044.
xDJxJUSTx is offline   Reply With Quote
Unread 09-24-2012, 10:30 AM   #6
RagTagSoldier
Registered User
1996 ZJ 
 
Join Date: Nov 2011
Location: bellefontaine, ohio
Posts: 683
Quote:
Originally Posted by xDJxJUSTx

Sorry, I meant rob84044.
Woow I though rob asked lol, total lapse in judgement sorry lmfao.

Sent from my iPhone using JeepForum
RagTagSoldier is offline   Reply With Quote
Unread 09-24-2012, 10:35 AM   #7
DickDickle
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Dracut, Ma
Posts: 531
Im using a valor unit in mine and the other day I lost all audio but still have bass from my woofer I took the radio out and checked my wiring and connections I get no audio from radio cd DVD or from the sd card and I have all the speakers wired right to the unit, I'm assuming its time for a new unit in my case
DickDickle is offline   Reply With Quote
Reply

Tags
electrical issue , radio
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.