Adding a digital vic? - Page 4 -

LinkBack Thread Tools
post #46 of 46 Old 08-15-2013, 10:19 AM
Registered User
1993 ZJ 
Join Date: Nov 2010
Location: Somewhere
Posts: 131
Both of my Jeeps had the oil sensor but I found it to be more trouble than it was worth. Others have said they've never experienced an issue, but before using a 3.3k ohm resistor to fool the VIC I constantly got "Check Oil Level" despite everything being fine.

"Those who say it cannot be done should not interrupt the one doing it." -Chinese Proverb
93' Grand Cherokee 5.2 Ltd. - Mine
93' Grand Wagoneer 5.2- Dad's
93' Grand Cherokee 4.0 Ltd. (Deceased)
Lakoswolf is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome