ABS light on 1998 Grand Cherokee - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > ABS light on 1998 Grand Cherokee

TJ Wrangler 4" Rough Country Suspension Lift Kits in Grizzly Lockers available at Rockridge4wd.comBds fox ipf 2.0 racing series shocks now available at rock

Reply
Unread 01-22-2009, 10:59 PM   #1
grapeman
Registered User
 
Join Date: Jan 2009
Location: Napa, ca
Posts: 2
ABS light on 1998 Grand Cherokee

Just purchased a 1998 Grand Cherokee. 113,00 miles. The abs light was on. Ran a code and it said pump failure. Determined pump motor was not running. Checked fuses, both good. Took motor off of pump and it was kinda hard to turn. Rotated it by hand a few times and it freed up. Put current to it and it ran fine. Put it back on the pump and no go. Any suggestions on where to go from here?

grapeman is offline   Reply With Quote Quick reply to this message
Unread 01-22-2009, 11:42 PM   #2
waarp8nt
Registered User
1995 ZJ 
 
Join Date: Sep 2008
Location: F-N-Ham, IL
Posts: 105
Check to see if there is power and ground going to the motor. You may have to have a helper pump the brakes as you check for power and ground.
waarp8nt is offline   Reply With Quote Quick reply to this message
Unread 06-02-2009, 02:33 PM   #3
chrisbean
Registered User
1998 ZJ 
 
Join Date: Nov 2007
Location: shreveport
Posts: 141
This MAy not work for you, did for me though.Not even sure if it had anything to do with ABS but my light came on one day after I did my front brakes. It would go off and on over the next 2 years. I never checked any codes or anyhting since they seem to work fine. Then I did my rear brakes and decieded to do the parking brake to since I had it for 5 years. After I di the park/rear brakes and tightened up the park linkage the light went of? (at the time it had stayed on for about 5 months straight). Not sure IF that helped it or not but it seemed to work for me.
chrisbean is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.