ABS light on - JeepForum.com

 
LinkBack Thread Tools
post #1 of 13 Old 08-16-2005, 10:15 AM Thread Starter
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
ABS light on

My Abs light has come on twice after driving thru an area were the speed limit is 20mph and requires some occasional stops for pedestrians. the first time i stoped down the road and turn the engine off for about 2mins then restarted and the light stayed on till we actually parked for an hour or more. it stayed off till sunday when driving thru the same area. I am not sure if it will stay off because i have not driven it since. would there be a code generated from this. my brakes are pretty new with rotors an calipers. any thoughts?


98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 08-16-2005, 10:35 AM
mr_user
Registered User
 
Join Date: Sep 2004
Location: Fairfield, CT and Oxford, OH
Posts: 2,067
Check for something easy first, like the ABS relay. It is located in the PDC on the passenger side of the motor.

Or you can just do what I did, and disconnect the ABS altogether..A new module is going to run you some big bucks if that's the case.


Matt

Old: '96 ZJ 4.0, 32" MT/R's, 4.5" Lift, Mickey Thompsons, JKS Disco's

New: '02 WJ Limited 4.7L, Stock for now
mr_user is offline  
post #3 of 13 Old 08-16-2005, 10:41 AM
ExplorerDMB
Registered User
 
Join Date: Aug 2005
Location: Mechanicsville, VA
Posts: 62
ABS Modules are indeed expensive. A new module for a BMW we had in the shop one day was around $1,000 uninstalled.

-Drew

Cherokee - '92 Laredo 4x4
Explorer - '00 XLT 4x4 7" Lift, 4.56s, LSD, 33's
ExplorerDMB is offline  
post #4 of 13 Old 08-16-2005, 11:52 AM Thread Starter
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
jive bmw's. i would hope its not that either

98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline  
post #5 of 13 Old 08-16-2005, 12:48 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
You should at least inspect the sensors. During the brake job it is very possible that one of the got bumped and is not exactly aligned with the sprocket.

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #6 of 13 Old 08-17-2005, 08:39 AM
rschunk
Registered User
 
rschunk's Avatar
 
Join Date: May 2005
Location: S.E. Indiana near Cincinnati
Posts: 146
ABS light on

Yep, had the ABS light on my old '97...stealer said the pump was bad and quoted me $560.00 just for the part. Never did get it fixed and traded for a 2002.

OTOH, I had the same light on my 93' GC after doing some 'mudding'. Figured it was mud so I used the high pressure wash to clean off the rear of the wheel and the connecting parts and the light went off.

I'd check for a bad connection. Don't know if it throws a code as I didn't know how to 'discover codes' then, but it probably does.

Good luck....

"Mean Green"
4.0 inline 6
3" BDS Suspension lift
ARB bumper with
T-Max 9000# Winch
Optima Yellow
JKS Swaybar Quick Disconnects
30x9 Dunlop Mud Rovers
Rocky Road Rockrails (Great rails, lousy shipping)
GPS Street Pilot
175,000 miles & still going!
93 Green GCL
Green Jeep Club Member #163

My Cherokee Page check out the pictures..




Also a 'Graphite' 2002 Grand Cherokee Laredo. Graphite Jeep Club Member #1
rschunk is offline  
post #7 of 13 Old 08-17-2005, 10:15 AM Thread Starter
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
well i drove it yesterday mostly hwy and the light never came back on. so it is probably a loose connection some place. will check it out this weekend

98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline  
post #8 of 13 Old 08-17-2005, 05:31 PM
jdpaysnoe
Registered User
 
Join Date: Apr 2004
Location: Oklahoma City, OK
Posts: 102
Mine goes on and off all the time. Along with my security light and my check engine light. I have tried to pull codes on all the blinking lights, but their are no codes so I have a feel its just a loose connection somewhere. I think the wiring on my whole Jeep is in shambles, but it still runs well and the thing is a bucket at this point anyways so I dont really care about it.

Jeremy
Leatherseats.com


1994 Black Grand Cherokee w/ Quad
-2" Budget Boost
-31" Pro Comp All-Terrains
-Kevin's Heavy Duty Adjustable Track Bar
-Okie Custom Antenna Mount
-Old Man Emu Steering Stabilizer (From Kevin's Offroad)
jdpaysnoe is offline  
post #9 of 13 Old 08-18-2005, 07:45 AM Thread Starter
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
im gonna stray a little hear, my jeep got broke into last weekend. nothing was stolen but they busted the right rear passenger side wing window . my alarm of course went off when they tried to open the door . what im wondering is why didnt jeep install a blinking light someplace on the 98 5.9ltd. i would bet the jeep wouldnt have even been touched if there was a light letting them know there was an alarm. Since there isnt one how would i go about installing one and have it only come on when the alarm is active?.
thanks

98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline  
post #10 of 13 Old 08-18-2005, 06:35 PM
Woody
Retired back to Bowties
 
Woody's Avatar
1985  
 
Join Date: Sep 2004
Location: North Pole, Alaska
Posts: 7,078
Quote:
Originally Posted by kemicalburns
im gonna stray a little hear, my jeep got broke into last weekend. nothing was stolen but they busted the right rear passenger side wing window . my alarm of course went off when they tried to open the door . what im wondering is why didnt jeep install a blinking light someplace on the 98 5.9ltd. i would bet the jeep wouldnt have even been touched if there was a light letting them know there was an alarm. Since there isnt one how would i go about installing one and have it only come on when the alarm is active?.
thanks

My security light blinks, but that's only in the dash.


Back to the original question, I think many Jeeps out there have Gremlin's built in that can cause confusion and frustration. My 99 WJ had several, so I got rid of it, interestingly enough, the 94 with tons of miles, has very few if any. HMMM....

Woody
1985 1 ton K-5, Detroit diesel, 36" tires (going bigger when money permits), 4-speed manual swap, Rockwell T-case, Hybrid lift, 12.5K winch.

Last edited by Woody; 08-18-2005 at 06:54 PM.
Woody is offline  
post #11 of 13 Old 08-19-2005, 03:56 PM
rschunk
Registered User
 
rschunk's Avatar
 
Join Date: May 2005
Location: S.E. Indiana near Cincinnati
Posts: 146
ABS light on

You could always get one of those little blinkers that bike riders wear. Stick it on the dash and turn it on when you get out....cheap fix...

"Mean Green"
4.0 inline 6
3" BDS Suspension lift
ARB bumper with
T-Max 9000# Winch
Optima Yellow
JKS Swaybar Quick Disconnects
30x9 Dunlop Mud Rovers
Rocky Road Rockrails (Great rails, lousy shipping)
GPS Street Pilot
175,000 miles & still going!
93 Green GCL
Green Jeep Club Member #163

My Cherokee Page check out the pictures..




Also a 'Graphite' 2002 Grand Cherokee Laredo. Graphite Jeep Club Member #1
rschunk is offline  
post #12 of 13 Old 08-19-2005, 03:57 PM Thread Starter
kemicalburns
Registered User
 
Join Date: Mar 2004
Location: Central Orygun
Posts: 192
thought about that. im just suprised mine doesnt have one unless its under the dash cover. never had it off but will look tonight just incase

98 limited
5.9ltr
stock
2.5" exhaust flowmaster
kemicalburns is offline  
post #13 of 13 Old 08-19-2005, 04:04 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
I added a blinking LED to my dash. I got it at radio shack. I power it with two AA batteries.

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
tail light not working - brake light does work gd929 ZJ Grand Cherokee Forum 2 06-17-2010 12:29 AM
OIL LEVEL GAUGE, AIR BAG LIGHT & ABS LIGHT SHOWING ON DASHBOARD - WJ Model babix0ashh ZJ Grand Cherokee Forum 6 01-19-2010 12:48 AM
gcl 4.0 driving light/brake light/turnsignal issues msherman1 ZJ Grand Cherokee Forum 1 01-05-2010 09:23 PM
Super cheap headlight, marker light, directional light kit... thoughts? aaron7 ZJ Grand Cherokee Forum 13 01-07-2009 06:17 PM
Tail Light and Instrument light problem t_guenther ZJ Grand Cherokee Forum 0 09-18-2008 07:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome