99 G Cherokee 4.0 won't shift out of first! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 11-14-2006, 04:20 PM Thread Starter
Shawn w
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2006
Location: South Carolina
Posts: 87
99 G Cherokee 4.0 won't shift out of first!

I have a 99 Grand cherokee 4.0 4WD. It will not shift out of first at all. It goes in reverse and drive fine. Goes in all 4wd settings fine.It acts just like if you pull the shifter all the way down in to the 1 st gear selection. It does not try to change at all just keeps reving till you let off the gas and then revs down. The fluid is clean and full, and there are no warning lights of any kind on. It seems wierd that the tranny would just go out like this, they usually slip. This one seems like soemthing electrical is going on. Any help is appreciated.

Thanks,
Shawn

Shawn w is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-15-2006, 01:50 PM Thread Starter
Shawn w
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2006
Location: South Carolina
Posts: 87
can anyone offer any help?

Thanks,
Shawn
Shawn w is offline  
post #3 of 9 Old 11-15-2006, 01:57 PM
Wiley
Registered User
 
Wiley's Avatar
 
Join Date: Dec 2005
Location: Carbondale, Illinois
Posts: 1,473
Is it throwing any codes?

Justin

1993 ZJ Laredo

5.2 V8 4" lift 31s JKS f & r track bars JKS discos Cragar Soft 8s DT 3000s OME Stabilizer
K&N drop-in Dynomax Exhaust Hella 500s Westin Safari Bar KOR Radiator Support
Dark Rosewood Jeep Club Member #5
Wiley is offline  
post #4 of 9 Old 11-15-2006, 02:01 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
If drive & reverse works and 1st gear does not, then it seems like a cable adjustment?

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #5 of 9 Old 11-16-2006, 04:11 PM Thread Starter
Shawn w
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2006
Location: South Carolina
Posts: 87
i checked codes and it only came back with done so I guess it is clear. Still looking for some answers.

Thanks,
Shawn
Shawn w is offline  
post #6 of 9 Old 11-16-2006, 07:47 PM
pulsepb
Registered User
2000 WJ 
 
Join Date: Nov 2005
Posts: 148
sounds like a transmission speed sensor. mine gave me a code and started doing exactly what you saying its an easy fix. just like changing a spark plug
pulsepb is offline  
post #7 of 9 Old 11-16-2006, 08:54 PM
corningjeff
Registered User
 
Join Date: Nov 2006
Location: Corning, NY
Posts: 5
My 99 GC did the same thing over a year ago. Turns out the inner transmission seals were worn & needed to be replaced - an expensive fix. Does it start to shift normally after the engine/tranny warm up? Mine did this, as the heat allowed the seals to swell a bit. However, over time it eventually didn't shift well even when warm.
corningjeff is offline  
post #8 of 9 Old 11-16-2006, 09:40 PM
GrandchampWJ02
Registered User
2006 WK 
 
Join Date: Jul 2006
Location: Thornton, Colorado
Posts: 193
Same thing happened to me in my 4.0 XJ a couple years ago. I had a check engine light though. It turned out to be the throttle position sensor (TPS). I believe it was about a $40-50 plastic sensor that was really easy to replace. Just a suggestion and I'm not sure if this will help with a WJ.

--Reid
'06 WK Laredo 4.7 Light Khaki
Colorado Jeep Club Member #36
Previous Jeeps:
'02 Black WJ Laredo 4.7, '96 Cherokee Classic Moss Green
GrandchampWJ02 is offline  
post #9 of 9 Old 11-17-2006, 07:34 AM Thread Starter
Shawn w
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2006
Location: South Carolina
Posts: 87
well i pulled the codes and there weren't any, and no it does not try to shift at all. just stays in first with out even attempting to shift.

Thanks,
Shawn
Shawn w is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
95 grand cherokee won't shift to OD cratebv212 ZJ Grand Cherokee Forum 3 11-22-2009 04:50 AM
Shift Problem 95 Grand Cherokee gromey ZJ Grand Cherokee Forum 0 04-24-2009 08:36 PM
93 grand cherokee hard shift ttavenieriii ZJ Grand Cherokee Forum 0 11-20-2008 05:30 PM
Shift kit for 97 jeep grand cherokee bvilletigers08 ZJ Grand Cherokee Forum 2 07-08-2008 03:51 PM
93' GR Cherokee 3rd-to-OD shift problem LEXMan ZJ Grand Cherokee Forum 17 05-31-2005 06:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome