98 ZJ 5.2L clicking Engine noise need help please - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 98 ZJ 5.2L clicking Engine noise need help please

WJ Shackle Tabs: Tow-Hook Replacements2014 Spartan Locker Special - While Supplies Last! Dana 3FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-22-2009, 10:16 AM   #1
t_guenther
Registered User
1995 ZJ 
 
Join Date: Apr 2007
Location: Ishpeming, MI
Posts: 65
98 ZJ 5.2L clicking Engine noise need help please

I just picked up a 98 ZJ with a 5.2L V8 for real cheap, and it has a heavy clicking noise coming from the engine on the passenger side. The noise only occurs when the engine is at normal operating temperature, and it does not do it at idle, it only makes the noise when the engine is revved up to around 2200 then it will make the noise continuously. The frequency of the clicking also increases as the RPM of the engine increases.
The jeep still drives fine, down the highway at 60 mph with no problems with hesitation, or loss of power. The previous owner had always used penzoil, which i have always had problems with, but thought at 91,000 miles major engine trouble is not to likely. My first thoughts were sticky valves or a lifter that has a problem. If anybody needs more information, i will do my best, and any help will be appreciated.

__________________
Michigan Tech. Univ. - MET, Senior

--95 Grand Cherokee 5.2L V8--
Front/Rear Adj. Track Bar, 249 to 231 Swap, Tie rod conversion,
Hella 500's, Flowmaster 50 Series, Aussie Locker in the Rear,
31x10.5 BFG All-Terrains on 15x8 Pro Comp 97 Crawlers, 3" Lift
t_guenther is offline   Reply With Quote Quick reply to this message
Unread 06-22-2009, 05:30 PM   #2
t_guenther
Registered User
1995 ZJ 
 
Join Date: Apr 2007
Location: Ishpeming, MI
Posts: 65
Update: Does not really seem like a valve train issue any more. Through more expirements, I found that the problem is made worse by removing the number 2 spark plug wire (first plug wire on the front of the engine on the passenger side). Also, if I hold the brakes to load the engine and rev it up i do not here the knocking sound. Also the magic RPM range is between 1200 and 1800, anything above or below and the sound does not exist. Because sounds are so hard to trace, now it seems to me like it may be in timing chain area, or bell housing.
__________________
Michigan Tech. Univ. - MET, Senior

--95 Grand Cherokee 5.2L V8--
Front/Rear Adj. Track Bar, 249 to 231 Swap, Tie rod conversion,
Hella 500's, Flowmaster 50 Series, Aussie Locker in the Rear,
31x10.5 BFG All-Terrains on 15x8 Pro Comp 97 Crawlers, 3" Lift
t_guenther is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.