98 JGC Laredo from one problem to the next - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 04-27-2011, 09:28 PM Thread Starter
gfd732
Registered User
1998 ZJ 
 
Join Date: Aug 2009
Location: Greenup Kentucky
Posts: 3
98 JGC Laredo from one problem to the next

I have a 98 JGC Laredo I6 4.0 recently I had a problem with not spark issues so I replaced the distributor, button, plugs, wires, coil pack, Distributor Pickup Assembly, Crankshaft sensor and after all that we finally get the jeep to give us a check engine light. we checked the code and it called for a new ASD relay. we changed it and it now sparks.

the new problem is now the jeep refuses to stay started. First started out with a miss after we put the ASD relay but now it will idle for a minute or 2 the shut down. i can get it to stay up a little bit longer if i lay the gas pedal on the floor. I found that it will die quicker if i turn the wheel or when it warms up. When it does shut down it is a violent shut down and sounds like engine just dropped out of the bottom of jeep.

I would appreciate and ideas anyone would have on this issue. I really like my jeep, however after today I am starting to second guess my loyalty to it.


Last edited by gfd732; 04-28-2011 at 08:11 AM.
gfd732 is offline  
Reply

Tags
dying , idle , missing , spark , start problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
'05 G.C. Laredo Gear Problem kingstonjeep WK Grand Cherokee & XK Commander Forum 2 04-02-2010 06:35 PM
tranmission problem - Laredo kutluay WK Grand Cherokee & XK Commander Forum 4 08-19-2009 01:50 PM
HELP!!!!!! WG Laredo Problem junebubby ZJ Grand Cherokee Forum 4 09-29-2008 12:51 AM
98 GC Laredo sputtering problem slokum ZJ Grand Cherokee Forum 2 05-08-2008 08:26 AM
VIC problem in my 94 Laredo OH-ZJ-IO ZJ Grand Cherokee Forum 6 01-18-2006 08:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome