98 Grand Cherokee Laredo - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 98 Grand Cherokee Laredo

JK specific skid plates from Clayton Off Road Mfg.RCV Heavy Duty Axle Shafts Now Shipping at Baseline4x4.comStainless Steel Door Hinge Pins

Reply
Unread 12-07-2012, 10:26 PM   #1
Merlin4542
Registered User
 
Join Date: Dec 2012
Location: Ogden, KS
Posts: 6
98 Grand Cherokee Laredo

Hey Y'all- I recently purchased a 98 Grand Cherokee Laredo w/ the V-8 as a fixer-upper. After I charged the battery and tried to start it, it runs for about 3 seconds and then dies. According to the previous owners, this is a recent problem and it was running great about 3 weeks ago- so bad gas isn't an issue. Tryin to get get it fixed w/ the least amount of effort and unanswered wishes, I replaced the the fuel pump relay and it obviously didn't work. You can hear the pump cycle when you turn on the key and try to start it, then it cuts out. I don't believe its the cam sensor because if it was, it wouldn't start. Any ideas would be greatly appreciated. Thanks for your time and input

Merlin4542 is offline   Reply With Quote
Unread 12-08-2012, 10:03 AM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: right now I'm in, Texas
Posts: 5,716
Classic security problem. It thinks it is being stolen.
What is the red LED on the dash doing?
Do all doors lock and unlock with FOB? Horn Beep? All seem okay with operation of system?
ZeeJay1997 is offline   Reply With Quote
Unread 12-16-2012, 03:31 PM   #3
Merlin4542
Registered User
 
Join Date: Dec 2012
Location: Ogden, KS
Posts: 6
Thanks for your input- turns out that after we got the FOB and jump started it- all was good with one minor exception. As i operated the FOB to unlock it, the back door unlocked and a grinding electronic/mechanical sound came out of the front drivers side door. The front door eventually unlocked after the 2nd/3rd attempt. Any ideas?
Merlin4542 is offline   Reply With Quote
Unread 12-16-2012, 04:51 PM   #4
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: right now I'm in, Texas
Posts: 5,716
Quote:
Originally Posted by Merlin4542 View Post
Thanks for your input- turns out that after we got the FOB and jump started it- all was good with one minor exception. As i operated the FOB to unlock it, the back door unlocked and a grinding electronic/mechanical sound came out of the front drivers side door. The front door eventually unlocked after the 2nd/3rd attempt. Any ideas?
The front drivers door is the first to go. Needs new door lock motors.

Work around is to not set security system. Use push locks to lock and key to get in.
ZeeJay1997 is offline   Reply With Quote
Unread 12-16-2012, 07:17 PM   #5
Merlin4542
Registered User
 
Join Date: Dec 2012
Location: Ogden, KS
Posts: 6
Thanks again for sharing your knowledge, i'll get this beast figured out sooner or later- i appreciate it. Wasn't sure if i could do that-
Merlin4542 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.