98 Grand Cherokee 5.9 transmission problems? - Page 2 - JeepForum.com

LinkBack Thread Tools
post #16 of 16 Old 05-11-2013, 02:32 PM Thread Starter
Registered User
1998 ZJ 
Join Date: Dec 2012
Location: El Paso
Posts: 33
Alright so my mechanic changed the governor sensor and the solenoid in my jeep and it was working just fine for a few days. Now its doing the same thing all over again check engine light is on and it seems to be stuck in second or third gear. What could be causing this to happen? Its the second time in a week and I don't want to pay another $350 to fix. Please help!

Georgeninner is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome