98 GC transmission shifting problem - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 98 GC transmission shifting problem

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail

Reply
Unread 12-20-2011, 07:03 AM   #31
ZickJagger
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 98
If the problem is the trans slipping in 1st but every other gear is strong...what would my options be??

ZickJagger is offline   Reply With Quote
Unread 12-20-2011, 11:35 AM   #32
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman, OK
Posts: 2,006
Will it slip when shifted into Manual 1, or just drive 1st
jnicewan is offline   Reply With Quote
Unread 12-21-2011, 08:42 AM   #33
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie, PA
Posts: 53
Quote:
Originally Posted by izackary View Post
Were the faulty conditions consistent with the gov sensor and solenoid? This one I drove seemed normal then off then ok again, then another random funny shift which seems more like a dirty sensor...
I narrowed mine down with a code scanner it have a manufacturer tranmission fault. But i think that the speed sensor will exhibit similiar symptoms as a faulty gov sensor and solenoid
dpjag is offline   Reply With Quote
Unread 12-21-2011, 01:00 PM   #34
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,788
They don't always throw a code when they go bad. Mine threw the code then went away and then came back again. The Oreilly's code scanner gave me the fault codes.
PolkaPower is online now   Reply With Quote
Unread 12-27-2011, 06:27 AM   #35
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie, PA
Posts: 53
Mine transmission as been acting up again with it not wanting to shift all the time. But it is not only in first. I think i am going to replace the speed sensor tonight and see if that helps since it is a $20 item
dpjag is offline   Reply With Quote
Unread 01-05-2012, 12:04 PM   #36
JeepStangNCSU
Registered User
1990 XJ Cherokee 
 
Join Date: Aug 2011
Location: Owasso, OK
Posts: 11
I have a 98 ZJ Limited 5.2L with 178k that seems to slip between 2nd and 3rd when the tranny is cold. After about 2 runs from 0-45 MPH it shifts perfectly fine. Do you guys think this is a pressure sensor/solenoid problem or is my tranny going out? I've changed the fluid and filter about 20k ago.
__________________
Justang
1990 XJ Cherokee Laredo 4.5" Lift and 31s
1998 ZJ Grand Cherokee Limited 5.2L Bone Stock
2002 WJ Grand Cherokee Limited 4.7L Bone Stock
JeepStangNCSU is offline   Reply With Quote
Unread 01-05-2012, 12:07 PM   #37
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,788
It's hard to say. A rebuild is pretty expensive compared to adjusting the bands and replacing the sensors. I always like to start with the cheapest fix first.
PolkaPower is online now   Reply With Quote
Unread 01-05-2012, 12:13 PM   #38
JeepStangNCSU
Registered User
1990 XJ Cherokee 
 
Join Date: Aug 2011
Location: Owasso, OK
Posts: 11
Yeah I agree. I guess the first smart thing to do is get my code scanner out and see what it tells me.
__________________
Justang
1990 XJ Cherokee Laredo 4.5" Lift and 31s
1998 ZJ Grand Cherokee Limited 5.2L Bone Stock
2002 WJ Grand Cherokee Limited 4.7L Bone Stock
JeepStangNCSU is offline   Reply With Quote
Unread 01-13-2012, 05:51 PM   #39
Bolo913
Registered User
1998 ZJ 
 
Join Date: May 2006
Posts: 2
My '98 Grand Cherokee 5.9 at times wants to up shift early at lower speeds than normal. Then at cruising speed 55 or 60 it will act like it's slipping, I notice the RPM's going up & down while this is happening. Any clues? Thanks
Bolo913 is offline   Reply With Quote
Unread 01-16-2012, 12:23 PM   #40
RIP50AK
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Alaska
Posts: 9
My 98 ZJ 4.0 tranny started haveing a hard time shifting into 2nd when cold. I had it serviced and it seemed to work better. Now about a month later it wouldn't shift into high. It was about -17F this morning and I don't know if that is affecting the shifting. If it is the cold would it likely be the selenoid?
RIP50AK is offline   Reply With Quote
Unread 01-17-2012, 07:02 AM   #41
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie, PA
Posts: 53
Quote:
Originally Posted by Bolo913 View Post
My '98 Grand Cherokee 5.9 at times wants to up shift early at lower speeds than normal. Then at cruising speed 55 or 60 it will act like it's slipping, I notice the RPM's going up & down while this is happening. Any clues? Thanks
Sounds like the lock-up on the tq converter is failing. Or could be a little low on fluid. I am not sure if you can unplug the converter to dissable the lock up or not. I have done it on a chryster car before. If it is shifting up to early it could be your kickdown needs adjusted.
dpjag is offline   Reply With Quote
Unread 01-17-2012, 07:04 AM   #42
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie, PA
Posts: 53
Quote:
Originally Posted by RIP50AK View Post
My 98 ZJ 4.0 tranny started haveing a hard time shifting into 2nd when cold. I had it serviced and it seemed to work better. Now about a month later it wouldn't shift into high. It was about -17F this morning and I don't know if that is affecting the shifting. If it is the cold would it likely be the selenoid?
It could be... i am not sure. How many miles on your jeep? Cold weather does strange things.
dpjag is offline   Reply With Quote
Unread 01-17-2012, 10:43 AM   #43
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss, MD
Posts: 15,788
Quote:
Originally Posted by Bolo913 View Post
My '98 Grand Cherokee 5.9 at times wants to up shift early at lower speeds than normal. Then at cruising speed 55 or 60 it will act like it's slipping, I notice the RPM's going up & down while this is happening. Any clues? Thanks
Try adjusting your TV cable. Not just the shift points but the housing adjustment. You could check your fluid and adjust your bands as well. See if any of that works. If none of that helps then start looking at the sensors.
PolkaPower is online now   Reply With Quote
Unread 01-20-2012, 09:43 AM   #44
1ATony
Vendor
1997 ZJ 
 
Join Date: Apr 2009
Location: mass
Posts: 4,488
My tranny slipped last night in 1st gear. I didn't let it warm up and left work It slipped in first and then after about a minute it shifted perfectly fine, and it shifts fine as long as I let it wark up for a minute when it's freezing out. I was thinking about having the tranny flushed in it, to get some fresh fluid in there.
__________________

Click Here^^ For a Great Selection Of Auto Repair Parts
1ATony is offline   Reply With Quote
Unread 02-14-2012, 01:38 PM   #45
Bolo913
Registered User
1998 ZJ 
 
Join Date: May 2006
Posts: 2
Quote:
Originally Posted by dpjag View Post
Sounds like the lock-up on the tq converter is failing. Or could be a little low on fluid. I am not sure if you can unplug the converter to dissable the lock up or not. I have done it on a chryster car before. If it is shifting up to early it could be your kickdown needs adjusted.
Well I took it to a trans guy who drove it and said he couldn't get it to do what i described. Go figure, Isn't that how it works!!
I've already replaced speed sensors, he did mention possible tq convertor lock up. Getting ready to take a long trip in it & getting kind of leary,,,,,would you?
Bolo913 is offline   Reply With Quote
Reply

Tags
first gear , shifting problem , transmission
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.