98 GC transmission shifting problem - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 45 Old 11-26-2011, 08:34 AM Thread Starter
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie
Posts: 53
98 GC transmission shifting problem

I have a 98 GC with the 5.2V8 limited and 151K miles. I beleive the transmission is the 42re. I went out the other day and it would not shift out of 1st gear. I did manage to get it to do it a few times.
If i would rev it up pretty high and take my foot off of the gas it shifted but only a few times. Then sometimes i could get it to shift up a gear of i did the same thing but kick it is neutral and back into drive.

The fluid and filter was changed a year ago... COuld it be the band needs adjusted?

Any help please

Thanks,
Darrell

dpjag is offline  
Sponsored Links
Advertisement
 
post #2 of 45 Old 11-27-2011, 08:59 AM Thread Starter
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie
Posts: 53
Bump any thoughts?
Maybe pressure sensor + solenoid in transmission?
dpjag is offline  
post #3 of 45 Old 11-27-2011, 09:04 AM
HiMileZj
Registered User
 
Join Date: Sep 2011
Location: Wilpo
Posts: 43
Governor pressure sensor and solenoid most likely..
I would pull the trans codes to see I believe its a 16 and something else just search trans codes on here and it will come up.
HiMileZj is offline  
post #4 of 45 Old 11-27-2011, 09:04 AM
ZJPunk98
Registered User
2002 WJ 
 
Join Date: Oct 2005
Location: North Kingstown
Posts: 2,353
i believe you have the 44re, i think the 42res come with the 4.0l. the bands may need adjusting. I know there are pressure switches which determine when a gear change is needed. Maybe one of these have failed.

edit: i have the FSM at home for this tranny, i can look up ideas later

Erik

98 ZJ 5.2L JGC Limited Sold
02 4.7L HO JGC Overland
ZJPunk98 is offline  
post #5 of 45 Old 11-27-2011, 09:44 AM Thread Starter
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie
Posts: 53
alright thank you... it has been about 2 years since the flush and then shortly after the flush i had to replace the tranny pan bc of rust so it had new fluid it in again. But when it shifted it was fine. No slipping or hesitation. Just one morning it wouldn't shift out of first. Just got it to do it a few times.
dpjag is offline  
post #6 of 45 Old 11-27-2011, 10:06 AM
HiMileZj
Registered User
 
Join Date: Sep 2011
Location: Wilpo
Posts: 43
when i bought my last jeep the lady thought the trans needed to be rebuilt (Wouldnt shift out of fisrt).. i took it off her hands and replaced the sensor and solenoid.. shifts like new now =]
HiMileZj is offline  
post #7 of 45 Old 11-27-2011, 11:29 AM Thread Starter
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie
Posts: 53
Quote:
Originally Posted by HiMileZj View Post
when i bought my last jeep the lady thought the trans needed to be rebuilt (Wouldnt shift out of fisrt).. i took it off her hands and replaced the sensor and solenoid.. shifts like new now =]
you mean the press sensor and solenoid in the valve body?
?
dpjag is offline  
post #8 of 45 Old 11-27-2011, 11:45 AM
jnicewan
Registered User
1995 ZJ 
 
Join Date: Dec 2010
Location: Norman
Posts: 2,348
There is also a speed sensor that is at the drivers side rear of the trans, on the o/d extension housing. Usually when this sensor fails it will stay in 1st and not upshift. This sensor influences the PCM to determine governor pressure. It could be the governor pressure sensor and solenoid too though. I would check it for codes though because either issue usually sets a code.
jnicewan is offline  
post #9 of 45 Old 11-27-2011, 12:03 PM
HiMileZj
Registered User
 
Join Date: Sep 2011
Location: Wilpo
Posts: 43
Quote:
Originally Posted by dpjag View Post
you mean the press sensor and solenoid in the valve body?
?
Yes best bet turn your key three times and manually pull your trans code by counting the flashes of the o/d switch on dash
HiMileZj is offline  
post #10 of 45 Old 11-29-2011, 08:27 AM Thread Starter
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie
Posts: 53
I tried turning the key and the o/d button does not flash....
dpjag is offline  
post #11 of 45 Old 11-29-2011, 08:37 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,421
Quote:
Originally Posted by HiMileZj View Post
Yes best bet turn your key three times and manually pull your trans code by counting the flashes of the o/d switch on dash
That only works with the 93-95 models. You need a code reader for the 96-98. If the gov pressure sensor and solenoid are going bad it may or may not throw a code. Mine threw a code then went away without clearing it. I have the parts on order. You can take it to an auto parts store and they may have a code reader for free. Oreily's had one. I just gave them my I.D. while I used it.
PolkaPower is online now  
post #12 of 45 Old 11-29-2011, 08:56 AM Thread Starter
dpjag
Registered User
 
Join Date: Sep 2011
Location: Erie
Posts: 53
Oh ok thanks ... i have a code reader i will try when i get home. I never thought to hook it up!
dpjag is offline  
post #13 of 45 Old 11-29-2011, 09:17 AM
PolkaPower
Registered User
1998 ZJ 
 
Join Date: Aug 2011
Location: The Abyss
Posts: 19,421
If it doesn't give you a code that doesn't mean the sensors are ok. They could still be malfunctioning.

PolkaPower is online now  
post #14 of 45 Old 11-29-2011, 11:59 PM
Degra101
Registered User
2007 JK Wrangler 
 
Join Date: Jan 2011
Location: Vancouver
Posts: 166
Damn thats a Fine *** Vid.

That right there should be stickyd !
Degra101 is offline  
post #15 of 45 Old 11-30-2011, 03:34 AM
93zjbums
Registered User
1993 ZJ 
 
Join Date: Feb 2011
Location: kalamazoo
Posts: 288
agreed never seen a vid any better

93 zj laredo 4.0 with k & n intake 2 inch bb skyjacker shocks and 31 bfg at
92 chevy cheyenne 4x4 w/t with 32in procomps "The Beast" 184k
92 honda accord ex
92 xj stock 358k miles wifes
93zjbums is offline  
Reply

Tags
first gear , shifting problem , transmission

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
GC having problems shifting. Transmission Problem? WM6405 WK Grand Cherokee & XK Commander Forum 9 04-19-2011 07:28 PM
transmission shifting problem, help please! customzj73 ZJ Grand Cherokee Forum 6 04-01-2010 11:51 PM
Transmission shifting problem 1st to 2nd flachman ZJ Grand Cherokee Forum 16 08-29-2009 09:24 PM
Transmission Problem...shifting 1st to 2nd rpsully8 ZJ Grand Cherokee Forum 3 01-30-2007 08:35 PM
'96 GC Transmission Shifting Problem When Cold tthomas436 ZJ Grand Cherokee Forum 5 10-04-2004 08:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome