97 Grand Cherokee won't start, no fire - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 01-14-2008, 07:19 PM Thread Starter
treed41
Registered User
 
Join Date: Jan 2008
Location: North Richland Hills
Posts: 4
97 Grand Cherokee won't start, no fire

I have a 97 Jeep Grand Cherokee, 93,000 miles and it would not start this morning. Recently replaced the battery and has ran fine for about 2 weeks. Its getting fuel to the fuel rail, but no fire at the spark plugs. I replaced the rotor and rotor cap, but no luck. After reading many forum entries, it seemed that the crankshaft position sensor resolved many problems with the cherokee not starting, so I replaced that but still no luck. I took the connector off the coil, and I have no voltage at that connector. I think I'm checking it correctly, and if I am there is no voltage going into the coil. Shouldn't there be 12V? Also checked all the fuses at the fuse block under the hood, and they all check out good. How can I verify the voltage at the coil, or what else can I check?

treed41 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 01-14-2008, 07:43 PM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
Pull the codes first:
Older (OBDI) models - Start with the ignition off. Within five seconds, switch the key on, off, on, off, on. ("On" is NOT "Start" and "Off" is NOT "Lock"). The "check engine" light will flash. Count the flashes. Each code is a two digit code, so a (for example) 23 would be FLASH FLASH (pause) FLASH FLASH FLASH (long pause). It will never flash more than 9 times, so watch for those pauses!

Newer (OBDII) models - Put the key into the ignition, push down the odometer reset button, then turn the key to RUN with your finger on the button - and then release the button. The odometer will go through 1111111 through 999999, then display the car's serial number. It will then show the error codes (it might show them starting with P). If this method does not work, try the OBDI method.

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #3 of 10 Old 01-14-2008, 10:00 PM Thread Starter
treed41
Registered User
 
Join Date: Jan 2008
Location: North Richland Hills
Posts: 4
I have tried both methods, multiple times but can't get any diagnostic codes to flash. I feel like I'm following the correct procedure, but after multiple tries, I still can't get anything to flash.

Would a diagnostic meter be able to provide the codes? Hate to purchase one and only use it 1 time, but it might be worth it.
treed41 is offline  
post #4 of 10 Old 01-15-2008, 12:31 AM
Jon08JK
Registered User
2008 JK Wrangler 
 
Join Date: Aug 2006
Location: Nampa
Posts: 368
What about your battery connections, have they worked loose from two weeks ago getting a new battery????

2008 Sahara Auto 2 Door 20,450 miles JKUR Coils and shocks, Magnaflow, Superchip, Banks CAI, Winch, OBA and 4:88's
Jon08JK is offline  
post #5 of 10 Old 01-15-2008, 05:02 AM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,306
If it tries to turn over but doesn't catch, ignition coil.


Hunter

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.366
Texas ZJ1 is offline  
post #6 of 10 Old 01-15-2008, 06:20 AM
Rockdaddy
Registered User
1993 XJ Cherokee 
 
Join Date: Oct 2005
Posts: 23
If there inst power to the coil, replacing it wont help. Need to find the issue with out power to coil
Rockdaddy is offline  
post #7 of 10 Old 01-15-2008, 07:25 AM Thread Starter
treed41
Registered User
 
Join Date: Jan 2008
Location: North Richland Hills
Posts: 4
Battery connections are fine. The starter turns at the proper speed to start the car.

Everything keeps coming back to the coil, and no voltage getting to it. Since I replaced the CPS, I'm wondering if that can stop the flow of voltage to the coil, if the air gap is not set right?

Also, what is the proper way to check the voltage at the coil? I'm have been disconnecting the leads going to the coil, turning the ignition to the on position, and checking for voltage. Nothing is there no matter how I hook up my meter. I know the meter is working correctly because I get 12V at the battery, and 5.10V at the CPS connector.
treed41 is offline  
post #8 of 10 Old 01-15-2008, 09:15 AM
greasefingers
Registered User
 
greasefingers's Avatar
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA
Posts: 8,237
Since the automatic shutdown relay feeds power to the fuel pump, injectors, and coil; then I would first swap out the A/C relay with the ASD relay.

Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline  
post #9 of 10 Old 01-15-2008, 09:34 AM
Pretty C
Member
2001 WJ 
 
Join Date: Apr 2007
Location: New Hampshire
Posts: 131
The engine coil is a 40 dollar part. I would replace it; i had problems with my 94 at 120 thousand miles. Do you have a I6 or a V8?
Pretty C is offline  
post #10 of 10 Old 01-15-2008, 11:40 AM Thread Starter
treed41
Registered User
 
Join Date: Jan 2008
Location: North Richland Hills
Posts: 4
I think the ASD relay might be faulty. I switched the ASD and the A/C relay, along with re-connecting the CPS and coil plug sockets, and it started up after that.

It seems to not like the cold weather, so will wait a few more cold mornings (if we get anymore of those in Texas) and see if it fails again. If it does, will probably switch out all the relays just to cover my bases.

Thanks for everyone's help for now, and if I have additional problems I will reply to this post.
treed41 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
HELP! My Grand Cherokee Won't Start CherokeeGal71 ZJ Grand Cherokee Forum 0 06-23-2008 06:54 AM
Grand Cherokee won't start rodneyj51 ZJ Grand Cherokee Forum 3 03-13-2006 08:55 PM
93 Grand Cherokee Won't Start 93gclaredo ZJ Grand Cherokee Forum 3 10-24-2005 06:03 AM
2005 Grand Cherokee recall (100,000 vehicles) - potential engine fire josephmartins ZJ Grand Cherokee Forum 2 10-22-2005 10:33 PM
Fire above fuel/gasoline tank on Grand Cherokee WJ Greg Christos WJ Grand Cherokee Forum 0 04-13-2002 01:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome