96zj 4.0 cuts in and out while driving?! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 96zj 4.0 cuts in and out while driving?!

ARTEC JK UNDER ARMOR - 4 door Bellypan KitsPoison Spyder DeFender Inner Fender KitsCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 06-15-2008, 11:41 AM   #1
1sportsdoc
Registered User
2010 JK Wrangler 
 
Join Date: Mar 2008
Location: So Cal
Posts: 358
96zj 4.0 cuts in and out while driving?!

my 96zj 4.0 cuts in and out, doesn't matter what speed and there's no pattern. It will cut out like it just ran out of gas but only for a moment, then's it's fine. The Check Engine light came on when it first happened but has since turned off. Doesn't run rough, just cuts out. Could it be a fuel thing, like a filter? Any input would be appreciated. Thanx.

1sportsdoc is offline   Reply With Quote
Unread 06-15-2008, 02:52 PM   #2
Virmagicus
Headed Out West
 
Virmagicus's Avatar
1998 ZJ 
 
Join Date: Feb 2006
Location: Northern Indiana
Posts: 6,428
Pull the codes. See if you have anything.
Virmagicus is offline   Reply With Quote
Unread 06-16-2008, 10:37 AM   #3
1sportsdoc
Registered User
2010 JK Wrangler 
 
Join Date: Mar 2008
Location: So Cal
Posts: 358
I don't have the equipment to do that, I'll have to take it in.
1sportsdoc is offline   Reply With Quote
Unread 06-16-2008, 05:22 PM   #4
MAUSS
Registered User
1996 ZJ 
 
Join Date: Aug 2005
Location: Charlottesville, Virginia
Posts: 786
The only "equipment" you need is your ignition key... turn the key on-off-on-off-on (without starting the engine) within 5 seconds and note the pattern of flashes of the Check Engine lamp. It will blink out the codes, if there are any, stored in the PCM. Look for 2 digit codes (a pause between the numbers). The number "55" indicates the end of the test.
Post the codes and someone here will be able to tell you what they mean.
__________________
'93 Limited (sold), '96 Laredo
MAUSS is offline   Reply With Quote
Unread 06-16-2008, 05:29 PM   #5
kongpheng
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2008
Location: sacramento
Posts: 217
Crank Position Sensor would be my guess as the culprit.

I had the same thing go wrong with my jeep at 150k.

In my situation, I didnt have a code, just the cutting in and out at any speed. Item runs for 80+ at autoparts store for my jeep. not sure if you have one on your jeep, but worth looking into. 20 min fix. make sure you have at least 2 feet worth of extensions and a swivel adapter. YOU WILL NEED IT unless your hands are smaller than an asian guy at 5'7" and a weight of 150. THAT asian guy would be me!!! so no one can say im talkin trash.

Goodluck
__________________
2001 Cherokee XJ Sport 4.0L
3" Rough Country Lift w/ Daystar 1.25" TC Drop Kit
Flowmaster Delta 40 Series
K&N Drop in Air Filter & Procomp 10" E-Fan
AirRaid TB spacer w/ 62mm Bored TB
BFG All-Terrain K.O. on Black ProComp 87's
kongpheng is offline   Reply With Quote
Unread 06-16-2008, 05:43 PM   #6
NYC_ZJ
Jeep for LIFE!!
 
NYC_ZJ's Avatar
1996 ZJ 
 
Join Date: Jul 2006
Location: Staten Island
Posts: 326
I had that same problem. Mine was the PCM...replaced it and no more cutting out. I went and changed everything else first...TPS, AIS, MAP, Crank pos sensor, cleaned throttle body. These things could be a contributing factor but not in my case. Good luck.
__________________
1996 ZJ - 4.0 w/ 164,000 miles
3" Rusty's springs, Bilstein 5150's, JKS Quicker Disco's, IRO Adj. Lower Control Arms, OME SS, KOR's adj. TB conv. kit, JKS Rear Track Bar,
31x10.5x15 Goodyear Dura-trac's on Ultra Rogue Wheels
ZJs Only club member #58
NYC_ZJ is offline   Reply With Quote
Unread 06-17-2008, 12:14 PM   #7
1sportsdoc
Registered User
2010 JK Wrangler 
 
Join Date: Mar 2008
Location: So Cal
Posts: 358
The Check engine light has gone off but the problem still exist. I tried the on-off-on with the key but nothing came up code wise. I remember about 8 months ago I had a similar problem and it turned out to be the Crank Sensor. The symptoms were different then. Back then the engine would run very rough, like it was on 2-3 cylinders. This time it just momentarily cuts out. I could try and check the CS according to the manual I guess. Thanks.
1sportsdoc is offline   Reply With Quote
Unread 04-18-2009, 03:27 PM   #8
don birkbeck
Registered User
1996 ZJ 
 
Join Date: Jan 2004
Location: westfield IN.
Posts: 3
green giant

had the exact same problem changed my computer( PCM) it was easy fifty bucks in junk yard no more problems
don birkbeck is offline   Reply With Quote
Unread 04-18-2009, 04:47 PM   #9
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,057
One more vote for the PCM.

Mine was doing the cutting off thing. Bought a scanner and figured out that every time it cut off, the drive cycle monitors reset and the key count set to 0.

50 bucks at a junkyard? Man I got ripped off. Gave 150 for mine. I was so tired of changing other parts that I really didnt care at the time.
ZeeJay1997 is offline   Reply With Quote
Unread 04-18-2009, 07:05 PM   #10
rooster51
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Virginia Beach
Posts: 1,634
3rd PCM vote, go now, get one
rooster51 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.