96 Transmission HELP - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 96 Transmission HELP

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits

Reply
Unread 08-28-2013, 06:31 PM   #1
DevJeep90
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: Boston, MA
Posts: 22
96 Transmission HELP

Hey guys, 96 ZJ 4.0, having trouble with my tranny. 42RE. 205,000 on it with original tran. I've been searching the forum for a month and reading the FAQs to no avail. Almost positive it's the tranny. 1st. When I'm in drive and accelerating from a stop my transmission jerks or kicks into gear. It will do the same thing when I come to a complete stop I feel and hear a kick or jerk. 2nd. When I first start the jeep it will shift hard into 3rd gear. Doesn't want to shift until I let off the gas a little and it will finally drop in. Only does it the one time when I first start driving. Changed the fluid and filter about a month ago. Any help would be great. Hoping my transmission isn't dying. Thanks


Last edited by DevJeep90; 09-04-2013 at 09:54 AM..
DevJeep90 is offline   Reply With Quote
Unread 08-28-2013, 07:33 PM   #2
edpmedic
Registered User
1995 ZJ 
 
Join Date: Nov 2011
Location: Baldwin, NY Long Island
Posts: 1,049
Did you also adjust the band's when you changed the oil and filter. Checked to make sure the intermediate and low reverse servos are not sticking in the bores? Have you tried it when not in overdrive? How does it shift when you manually shift it? Does it still have the same problem? Chances are with that much mileage it's time for a master rebuild or a rebuilt trans. I'm not sure how the throttle valve linkage works on the RE version. I had the 46RH which had an adjustable throttle valve cable.
__________________
Never4get those who gave their lives on 09-11-01 WTC and Pentagon. FDNY-EMS-NYPD-PAPD. Also those who are still dying.
_______________________________________________
"Freedom is never voluntarily given by the oppressor; it must be demanded by the oppressed."
Martin Luther King, Jr.
_______________________________________________
"Always aim at complete harmony of thought and word and deed. Always aim at purifying your thoughts and everything will be well."
Mahatma Gandhi
_______________________________________________
Feel the Sunshine on your face
edpmedic is offline   Reply With Quote
Unread 08-28-2013, 09:30 PM   #3
DevJeep90
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: Boston, MA
Posts: 22
Didn't adjust the bands but it's something that I might have to do. Not at all sure how to check the servos.....have to research that. I'll try it without overdrive tomorrow. My apologies but it shifts into 2nd gear......it's getting out and into 3rd thats hard. Could this be a TV cable issue? Hate to have to rebuild the trans.
DevJeep90 is offline   Reply With Quote
Unread 08-30-2013, 08:01 AM   #4
DevJeep90
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: Boston, MA
Posts: 22
Drove it without overdrive and it was no longer jerking when I came to a stop or let off the brakes to start moving again. Once I put overdrive back on it would start doing it again. Anyone heard of this before? Any ideas? Thanks
DevJeep90 is offline   Reply With Quote
Unread 09-03-2013, 05:27 AM   #5
edpmedic
Registered User
1995 ZJ 
 
Join Date: Nov 2011
Location: Baldwin, NY Long Island
Posts: 1,049
Sorry took so long to get back. I was looking for the online shop manual for the trans. I know if you do a search going back a little more then a year ago. There is a link for the 46re trans. Do a search under edpmedic for transmission or band adjustment and I think the link is there. I only have my phone and it's a PITA trying to find it. I think your problem is related to a solenoid on the valve body, but I'm really not sure.

It's one of those scribd on line documents. Maybe you can search for it that way. Also is your overdrive light flashing. I think that is where the trans codes are read by counting the blinks like the CEL.
__________________
Never4get those who gave their lives on 09-11-01 WTC and Pentagon. FDNY-EMS-NYPD-PAPD. Also those who are still dying.
_______________________________________________
"Freedom is never voluntarily given by the oppressor; it must be demanded by the oppressed."
Martin Luther King, Jr.
_______________________________________________
"Always aim at complete harmony of thought and word and deed. Always aim at purifying your thoughts and everything will be well."
Mahatma Gandhi
_______________________________________________
Feel the Sunshine on your face
edpmedic is offline   Reply With Quote
Unread 09-03-2013, 07:45 AM   #6
JS97ZJ
Registered User
1997 ZJ 
 
Join Date: Dec 2009
Location: Dingmans Ferry, PA
Posts: 2,035
Courtesy of Morris 4X4...knowledge base section of their website.

http://www.jeep4x4center.com/jeep-se....swf#toolbar=0
JS97ZJ is offline   Reply With Quote
Unread 09-04-2013, 09:50 AM   #7
DevJeep90
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: Boston, MA
Posts: 22
Thanks for the info guys. I'm going to try and change the solenoids this weekend and see how that goes. If there's no improvement which I'm guessing there won't be, I'll work on adjusting the bands. I drove it without OD and I could notice a little jerk on start and stops but nothing compared to what it does with OD. My other trans issue -->The hard shifting into 3rd seems to be intermittent. Sometimes it will do it (only once the 1st time it shifts into 3rd) and sometimes it won't do it at all. Might even shift easier into 3rd when i accelerate hard rather than taking it slow. I'm thinking this is unrelated to my other issue and is may be a TV cable issue/adjustment. I'm no expert by anymeans so i could be waaayyyy off.
DevJeep90 is offline   Reply With Quote
Unread 09-04-2013, 09:56 AM   #8
JohnnyZJ
Web Wheeler
 
JohnnyZJ's Avatar
1992 YJ Wrangler 
 
Join Date: Oct 2008
Location: Calgary
Posts: 2,271
od solenoid. probably got dirty and bunged up.
i'd swap it if you're pulling the pan again. also, put a drain plug in the pan and flush the tranny a few times. there is a lot of fluid in the transmission; it takes about 2-3 times to clean all the old crap out.
__________________
92 YJ ~ locked/33" swampers
05' WK Hemi limited ~ wifey mobile
13' Chevy Cruze ~ boo
13' GMC Sierra ~ 2.5" lift 33" MTs.
RIP 95 ZJ ~ 33s built/longarmed/locked/awesome Feb 2014 ZJOTM winner
JohnnyZJ is offline   Reply With Quote
Unread 09-04-2013, 11:13 AM   #9
DevJeep90
Registered User
1996 ZJ 
 
Join Date: Jul 2013
Location: Boston, MA
Posts: 22
That sounds good. I'll do that too.
DevJeep90 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.