96' Jeep grand Cherokee Limited Misfiring - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 03-20-2014, 05:04 PM Thread Starter
gemir69
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2014
Location: lakeside
Posts: 1
96' Jeep grand Cherokee Limited Misfiring

I have a 1996 jeep grand Cherokee limited 5.2L V8 and I am getting misfire codes p0300,p0308,p0301,p302, p303, p0304 in that order. I have replaces the spark plugs, wires, rotor, distributor and all 8 fuel injectors. I replaced the injectors because I was getting the codes that 2 and 4 were bad along with all cylinders misfiring and the random misfire. After I replaced the injectors and cleared all the codes, I got the earlier mentioned codes specifically. It does idle rough but not as bad since I changed the injectors. It runs better during operation until I get to 55mph and then the check engine light flashes for 30 seconds and then goes solid. It seems to stutter a bit at higher acceleration. Can anyone give me insight on what it could be.

gemir69 is offline  
Reply

Tags
check engine light , misfire cyl , rough idle

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome