post #1 of Old 10-16-2013, 05:35 PM Thread Starter
Ibanezltd
Registered User
1996 ZJ 
 
Join Date: Oct 2013
Location: Wilmington
Posts: 1
96 Grand Cherokee Laredo 4.0 Starting and stalling problems.

Hello, My name is Andrew, I just joined JeepForum.com, I always found it helpful in the past via googling info. I am having an incredibly frustrating issue with my Jeep.

Here are the problems:

At idle the RPM's will drop suddenly and the engine shakes and stutters badly, sometimes the rpm's will raise back up to normal idle, and sometimes the vehicle dies altogether.

While driving along the Jeep's rpm's will drop, pressing the gas pedal will do nothing, then all the sudden it will rev back up and drive fine. On the other hand, pressing the gas pedal will rev a small bit but will die after shaking and stuttering badly.

Sometimes the vehicle will not even start for about 20 mins after engine shutoff. It turns over and occasionally it seems like it is about to start but gives out.

I have replaced the plugs, wires, and the crank sensor, the previous owner stated that the PCM had been replaced though how truthful it is I am no sure.

Any assistance would be greatly appreciated I am at a loss. Thank-You very much.

Ibanezltd is offline  
post #2 of Old 10-16-2013, 06:49 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,549
sounds like low fuel pressure. there's a port on the rail. get a gauge on loan from advance auto or another parts store. should read 49 plus or minus 5
ZeeJay1997 is online now  
Reply

Tags
4.0 , 96 grand cherokee , dies , shaking , won't start


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome