96 GC. "Coolant Sensor Bad", Which sensor? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 07-14-2007, 08:15 AM Thread Starter
seanf
Registered User
 
Join Date: Jul 2007
Location: Littleton, CO
Posts: 5
96 GC. "Coolant Sensor Bad", Which sensor?

Intemittently, the electronic display with the little picture of the vehicle will say "Coolant Sensor Bad". Does anybody out there know if this is the Coolant temperature sensor or the coolant level sensor.

Thanks


1996 Grand Cherokee. Stock with 235 x 75 x 15 BFG all Terrain TA. 180k miles. I am the original owner
seanf is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-14-2007, 08:35 AM
kjopen
Registered User
1997 ZJ 
 
Join Date: Apr 2006
Posts: 142
Many of us have had this problem. It turns out that the problem is a dry joint on the VIC itself. Here's a link to how to fix it etc. :-

http://www.jeepforum.com/forum/f13/what-solder-432200/
kjopen is offline  
post #3 of 3 Old 07-14-2007, 04:16 PM Thread Starter
seanf
Registered User
 
Join Date: Jul 2007
Location: Littleton, CO
Posts: 5
Thanks, I guess I should have searched for that one...

1996 Grand Cherokee. Stock with 235 x 75 x 15 BFG all Terrain TA. 180k miles. I am the original owner
seanf is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
"Coolant Sensor Bad" FINALLY FIXED!!!! phild328 ZJ Grand Cherokee Forum 139 02-08-2016 08:17 AM
"Coolant Sensor is bad" jhillstead ZJ Grand Cherokee Forum 4 07-02-2009 10:18 PM
"Coolant Sensor Bad" seth586 ZJ Grand Cherokee Forum 5 06-21-2007 11:35 AM
"Coolant Sensor Bad"?? on '96 ZJ 5.2 oneillsean ZJ Grand Cherokee Forum 16 09-17-2006 12:14 PM
"Coolant sensor bad" Rock1127 ZJ Grand Cherokee Forum 1 10-01-2005 09:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome