95 zj sputters when reach normal running temp?? help - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 95 zj sputters when reach normal running temp?? help

Engo winches available at www.rockridge4wd.com! Free shippFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-13-2010, 01:37 AM   #16
thecooptn
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: tennessee
Posts: 13
So my ZJ has 289000 miles on it and motor still purrs until today, the tranny went south about a year and a half ago and it sat in the back yard untill last month when I put a good used tranny in. Changed ALL fluids, new distributer cap, rotor and plugs. drove it around the last couple of weekends and it ran fine until today when I was going to get emission test and new tags then it started sputtering and barely limped home but never died. I'm and ex Jeep worker from the Toledo plant, my dad's an ex Jeep engineer who bought this ZJ new and took really good care of it, sold it to me at 150000 and it never had a problem until the tranny and the sputtering today. The check engine light did come on today and I tried to get it to throw a code but the turning on the ignition 3 times wont show any codes. Thanks for all the help!!!! COOP

thecooptn is offline   Reply With Quote
Unread 08-13-2010, 02:20 AM   #17
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia, SC
Posts: 2,108
Maybe check the pressure at the fuel rail too ???

Just a thought ...

Phit
phitmein is offline   Reply With Quote
Unread 08-13-2010, 03:29 AM   #18
thecooptn
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: tennessee
Posts: 13
I also put a rebuilt fuel pump in it the other week due to no fuel pumping from the fuel pump lines, it started right and ran fine until today. What is the 1st, 2nd, 3rd things I should check. would a faulty pump cause it to stutter but not die? Is there 2 coolant temperature sensors? Thanks again for all the help. I going to sleep now (work 2nd-3rd shift) for a few hours and then up and to the jeep... COOP
thecooptn is offline   Reply With Quote
Unread 08-13-2010, 04:18 AM   #19
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia, SC
Posts: 2,108
The word rebuilt, scares me, because I have had very,very bad luck with Vatozone's alternators and starters, and I now do my very best to avoid them ...

Check the pressure at the rail ???

Edit: Have you read this thread ???

http://www.jeepforum.com/forum/f13/g...tters-1071035/

Phit
phitmein is offline   Reply With Quote
Unread 08-15-2010, 03:12 PM   #20
alilredjeep
Registered User
1992 YJ Wrangler 
 
Join Date: Sep 2003
Location: Opp, Alabama
Posts: 340
Quote:
Originally Posted by thecooptn View Post
Is there 2 coolant temperature sensors? COOP
Sorry for the late reply.

There was in '92 at least on my 2.5 Wrangler.
One sends info to the dash guage and one sends info to the computer to adjust the fuel ratio depending on engine temp.

Did you ever get things straightend out?
__________________
Eddie
RED JEEP CLUB MEMBER #92

'92 WRANGLER, 2.5 Litre, 5 Speed, Rag Top, Superwinch LP8500, Cepek 130W Driving Lights, 31x10.50/AT with no lift, Of course! It rubs!
alilredjeep is offline   Reply With Quote
Reply

Tags
4.0 , sputters , zj
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.