95 Grand CHerokee - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > 95 Grand CHerokee

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 11-12-2013, 07:06 AM   #1
Ernesto007
Registered User
 
Join Date: Nov 2013
Posts: 2
95 Grand CHerokee

95 Grand Cherokee starts and idles fine but dies if i put it in gear any gear Please Help

Ernesto007 is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 10:57 AM   #2
ryanfuscozj
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Jacksonville, Florida
Posts: 56
Could be a timing issue
ryanfuscozj is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 01:42 PM   #3
pmillz09
Registered User
1994 ZJ 
 
Join Date: Oct 2013
Location: fountain valley, ca
Posts: 12
I just had that problem. Clean the iac. Wen it does and u fire it back up does the check engine come on?
pmillz09 is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 02:09 PM   #4
bigbill888
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: michigan
Posts: 968
Check torque converter clutch solenoid. I don't know how to do it, but
google it.
__________________
96 ZJ Laredo, 4.0, 242, 230K
95 ZJ Limited, 4.0, 242, 140K
98 XJ Sport, 4.0, 231, 140K
All work well
bigbill888 is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 02:38 PM   #5
ryanfuscozj
Registered User
1996 ZJ 
 
Join Date: Apr 2013
Location: Jacksonville, Florida
Posts: 56
That happened on my brothers cummins, different because it's a diesel and his was due to poorly positioned governor springs
ryanfuscozj is offline   Reply With Quote Quick reply to this message
Unread 11-21-2013, 03:19 PM   #6
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Check the transmission fluid while running warm in neutral. When is the last time you changed the filter? Any engine light codes? Could be the Governor Pressure Sensor/Solenoid, but start with the basics first.
JasonStebbins is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.