post #1 of Old 09-09-2009, 01:42 PM Thread Starter
95redgc
Registered User
 
Join Date: Apr 2009
Location: Earlville, illinois
Posts: 38
95 4.0l oil burner?

I just finially put an full exhaust on it from manifold back i put a dynomax system on it. the old system was full of holes. any ways. now i notice the smell of burning oil out the tail pipe. on start up from cold or hot it give a little puff of white/blue smoke. today i had it running and was at operating temp and i left it idling for 10 min and when i came out it looked like a 2 stroke running. i am currently at 2500 miles and i am a just about to the add line. any ideas on the issue here? its a 95 jeep grand cherokke 4.0l

95redgc is offline  
post #2 of Old 09-09-2009, 01:52 PM
LordHobbit
Registered User
1993 ZJ 
 
Join Date: Aug 2009
Location: Oregon
Posts: 2,029
Nearly a quart at 2500 miles isn't bad, unless at 2400 miles you were clear full!! How many miles/hours on the new exhaust?

Could be valves, rings, several others. Have you done a compression test? How many total miles on the engine?

93 red ZJ 190k 4.0. Spent more money than I should have ...

Isn't red the only color a vehicle should be?
If at first you don't succeed, use more speed.
LordHobbit is offline  
post #3 of Old 09-09-2009, 01:56 PM
04KJlimited
Registered User
2004 KJ Liberty 
 
Join Date: Jan 2007
Location: connecticut
Posts: 167
check the PCV line from the valve cover to the air filter housing, there is a restriction in there to keep oil out of the intake, if the restriction breaks off it will suck oil from the valve cover into the air intake, and burn oil and smoke quite a bit. I know they sell the piece at napa, as i bought one for my old XJ
04KJlimited is offline  
post #4 of Old 09-09-2009, 02:05 PM Thread Starter
95redgc
Registered User
 
Join Date: Apr 2009
Location: Earlville, illinois
Posts: 38
162k miles on it and the hose that runs to the air filter broke and i just have it hooked up as a draft tube now. prolly got 300 miles on new exhaust system. i wanna do a comp and leak down on it but done have the tools gonna prolly have to buy a kit.
95redgc is offline  
post #5 of Old 09-10-2009, 11:14 AM Thread Starter
95redgc
Registered User
 
Join Date: Apr 2009
Location: Earlville, illinois
Posts: 38
i am also running rottela 15w40 oil along with motorcraft fl1a filter
95redgc is offline  
post #6 of Old 09-10-2009, 07:37 PM
easterfudge
Registered User
 
Join Date: Sep 2009
Location: here
Posts: 34
Mine does the same thing. 223,000 miles. I just replaced my crankcase vent orifice and cleaned all the piping. If it sits and idles it starts to puff it out. Don't have to worry about mosquitos in the yard w/ it running, that's for sure. I just figure it's old worn out rings. I paid less than $800 for the thing so if I have to put another engine in it, oh well.
easterfudge is offline  
post #7 of Old 09-15-2009, 01:14 PM Thread Starter
95redgc
Registered User
 
Join Date: Apr 2009
Location: Earlville, illinois
Posts: 38
can you pull the pistons with the motor still in the vehicle? cause i have thought about doing a rebuild on it the body is in great shap just starting to consuming a little too much oil for my likings.
95redgc is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Gas guzzler/brake burner davie360 ZJ Grand Cherokee Forum 3 10-24-2005 02:11 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome